3

My literature entries are formatted in English despite the use of \usepackage[ngerman]{babel}. For example, it says "Author1 and Author2" but I want it "Author1 und Author2". "Literatur" instead of "References" however works.

main.tex:

\documentclass{scrartcl}

\usepackage[ngerman]{babel}
\usepackage[round]{natbib}
\usepackage[final]{pdfpages}
\usepackage[utf8]{inputenc}

\begin{document}

Lorem ipsum \citep{DoeMustermann2014}.

\cleardoublepage
\bibliographystyle{agsm}
\bibliography{test}

\end{document}

test.bib:

@book{DoeMustermann2014,
  title = {{That awful German language}},
  Author= {John Doe and Max Mustermann},
  publisher = {English-German Friendship},
  address = {Hamburg - New York},
  Year  = {2014}
}
  • Strange... because I do. I'm running on Ubuntu 14.04, using Kile. – MERose Nov 5 '15 at 13:35
  • And what do you see instead if I may ask? – MERose Nov 5 '15 at 13:41
  • I think there is no way for that without some hacking in the installed natbib files. It is quite outdated. Did you tried biber with biblatex? – buhtz Nov 5 '15 at 13:57
  • natbib is outdated? Didn't know that. I'll look around for biber - never heard. – MERose Nov 5 '15 at 13:59
  • See also this question (not an exact duplicate, but providing more answers): tex.stackexchange.com/questions/279591/… – jk - Reinstate Monica Nov 23 '15 at 18:14
2

The agsm-Style uses a command for the and. So you are in luck and can adapt it (but biblatex/biber is naturally much more flexible):

\documentclass{scrartcl}

\usepackage[ngerman]{babel}
\usepackage[round]{natbib}
\usepackage[final]{pdfpages}
\usepackage[utf8]{inputenc}
\newcommand\harvardand{und}
\begin{document}

Lorem ipsum \citep{DoeMustermann2014}.

\cleardoublepage
\bibliographystyle{agsm}
\bibliography{test}

\end{document}

enter image description here

| improve this answer | |
  • Depending on the position in the text, one must use \renewcommand\harvardand{und}. – MERose Nov 5 '15 at 14:23
1

The babel package localises the normal LaTeX settings, but not the thingies coming from BibTeX. You need a localised BibTeX style (bst) for this purpose. e.g., natdin.bst.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.