9

I am using Texstudio (2.10.4). A great and useful function of the integrated visualizer is that if I right click at some point of the pdf, I can go to the corresponding code. This worked well in the previous versions of Texstudio. Now, when I click right the visualizer goes to the next page and the "go to source code" becomes less useful!

Any idea how I can fix this ?

Update: I got an answer from one of the TeXstudio's developer. I add my reply.

I am not aware that anything was changed concerning the right click in the pdf viewer.

This problem is probably not related to the update of TeXstudio but to my new computer and its configuration. However, it seems that I am not the only one to experience this issue.

Apart from that ctrl+left click should jump to source directly.

A useful recommendation. Unfortunately it does not work for me. left click or ctrl+left click jumps me to the next page.

4

I also had this bug recently. The bug is not related with the actual application; it is due to corrupted profile. This is what I learned after some experimentation. So, for the Mac OS, look at your home directory--> there is a hidden Config folder there. There is Texstudio folder inside the config folder. Close Textstudio and remove the Texstudio.ini (the profile file) file in the folder. Texstudio will recreate the file when you restart it. This fixes the problem.

4

New answer inspired by @Dellu: you need to restore the default settings to fix this problem. Just delete the settings file (texstudio.ini), while Texstudio is not running. Otherwise it will recreate the file with the present settings on closing. Note: If you only want to restore the default settings temporarily, rename texstudio.ini (e.g. texstudio-backup.ini).

Update that might be helpful for other users: I upgraded to TeXstudio 2.12.16. Then, while I was in the editor I used the "go to PDF" command, nothing happened. Moreover, I right-clicked on the PDF, there was no option "go to source". I solved this issue again by deleting the default settings (texstudio.ini, which is on C:\Users...\AppData\Roaming\texstudio in Windows 7), while Texstudio is not running.

Old answer: Let me post a simple trick: left click in the pdf viewer goes one page down, then right click goes one page up and the "go to source code" opens!

  • 1
    old is gold for me;-) – novice May 6 '18 at 18:40
  • @emeryville: The old answer seems to be the best one. – Rene Duchamp Nov 15 '18 at 16:10
0

I had this same issue, which turns out to be a bug. It worked for me to just press the icon picturing a hand on top of the in-line viewer (it was currently toggled to the magnifying glass). I imagine simply restarting the editor may have worked as well.

0

First check if the feature is still working on smaller documents. If it does, the problem is in the length of the file, as apparently it does not work on "too long" .tex files.

To solve it you can split it in two external files .tex and import them with \import in a main file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.