0

I wrote \include{{"Folder_A/B/C/D/M"}}. LaTeX reported that it could not write the 'Folder_A/B/C/D/M.aux' file. Is it because my file is too deep? Any idea? THX! OK. Someone told me this short version could work, then how about the long version of my path? Literature_review/ABCDEFG/ABCDEFG/ABCDEF_ab_ABCDEFGHIJKL_abc_ABCDEFGH/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH? That could represent the length of my path. I'm using the online editor Sharelatex. The error message was:

\@include ...\immediate \openout \@partaux #1.aux 
                          \immediate \write \@partau...
l.6 ...s/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH}

(Press Enter to retry, or Control-D to exit; default file extension is `.tex') 
Please type another output file name ! Emergency stop.
\@include ...\immediate \openout \@partaux #1.aux 
                          \immediate \write \@partau...
l.6 ...s/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH}

By the way, someone said I should use this format \include{Folder_A/B/C/D/M} instead of \include{{"Folder_A/B/C/D/M"}}. Neither of them would work. The format I used was to preserve the file path. It doesn't matter. If the first format could work, then the second would work too.

OK. The file looks like:

\documentclass[12pt,twoside]{report}
\setlength{\parskip}{1em}

%\usepackage[UKenglish]{babel}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\graphicspath{{"Research_report/XXXX_XXXXXXXXXXXXXXXX_XXXXXX/Images/"}}
\usepackage{ccaption}
\usepackage{caption}
\usepackage[capposition=bottom]{floatrow}
\usepackage{subcaption}
\usepackage{wasysym}
\usepackage[euler]{textgreek}
\usepackage{siunitx}
\usepackage{gensymb}
\usepackage{fixltx2e}
\usepackage[hidelinks]{hyperref}
\usepackage{chngcntr}
\counterwithin*{chapter}{part}

\usepackage[a4paper,width=150mm,top=25mm,bottom=25mm,bindingoffset=6mm]{geometry}
\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhf{}
\renewcommand{\headrulewidth}{0.4pt}
\renewcommand{\footrulewidth}{0.0pt}

\usepackage[sort, authoryear]{natbib}
%\bibliographystyle{dinat}
\bibliographystyle{unsrtnat}
%\usepackage[duplicate]{chapterbib}
\usepackage[UKenglish]{babel}

\fancyhead[RE]{\rightmark}
\fancyhead[LO]{\rightmark}
\fancyfoot{}
\fancyfoot[LE,RO]{Page \thepage}

\begin{document}

\input{titlepage}
\newpage\null\thispagestyle{empty}\newpage
\setcounter{page}{1}

\input{abstract}

\tableofcontents

\part{Literature review}
\fancyhead[LO]{\chaptername\ \thechapter}
\input{"Literature_review/main_Lit_Rev.tex"}


\part{Research report}
\listoffigures
\listoftables
\fancyhead[LO]{\chaptername\ \thechapter}
\input{"Research_report/main_Res_Rep.tex"}

\clearpage
\fancyhead[LO]{\rightmark}
\fancyhead[RE]{\rightmark}

\bibliography{References.bib}

\end{document} 

And this is part of my main_Lit_Rev.tex

\chapter {XXXXXX ab \textit{XXXXXXXXXX} abc \textit{XXXXXXXX}}
\include{{"Literature_review/ABCDEFG/ABCDEFG/ABCDEF_ab_ABCDEFGHIJKL_abc_ABCDEFGH/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH"}}
% This code below doesn't work either 
% \include{Literature_review/ABCDEFG/ABCDEFG/ABCDEF_ab_ABCDEFGHIJKL_abc_ABCDEFGH/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH}
  • 1
    I tried to reproduce your issue setting a similar path. All is well for me. Please read this guide and this guide to learn about our style. – OSjerick Nov 5 '15 at 23:44
  • @OSjerick: Sorry. How about this then Literature_review/ABCDEFG/ABCDEFG/ABCDEF_ab_ABCDEFGHIJKL_abc_ABCDEFGH/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH? That could represent the length of my path. – fyang Nov 5 '15 at 23:54
  • 1
    Please provide a minimal file showing the exact problem. You'd need to tell us the exact layout. – vonbrand Nov 6 '15 at 0:23
  • 2
    @fyang No, the extra braces do not have that effect in latex (unless you are using luatex) (and even in luatex they would not have that effect with \include as they are dropped due to macro argument processing. – David Carlisle Nov 6 '15 at 0:41
  • 1
    No you don't need to post them. Test to see if they are responsible. If not, omit them. You don't want \chapter{}\include{}. You want the \chapter in the included file. (This isn't the problem, but it is nonetheless true. \include{} always issues a new page.) – cfr Nov 6 '15 at 0:48
2

In your question you told us the path would be something like this:

Literature_review/ABCDEFG/ABCDEFG/ABCDEF_ab_ABCDEFGHIJKL_abc_ABCDEFGH/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH
%                                                               ^^^^^

but in the cited error message I saw:

l.6 ...s/ABCD_ABCDEFG_ab_ABCDEFGHIJKL_abc_ABCDEFGH
%   ^^^^

Where does the ...s come from? I think the error is hidden in this s part not shown to us.

I guess at last you have a special character in your path disturbing the system, like à, é etc.

If this guess does not help you, please show us the real path you used, and please complete it! (for windows: c:\mylatex\...GH)

Without better informations more I can not say ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.