1

I'm new to LaTex and already figuring out some problems with my bibliography. Some references are not shown in the bibliography, although they are cited. BUT, furthermore, if I do not cite anything, there is still one entry kept in the bibliography (the first one in my bib file).

Here's an overview of what I did so far:

  1. I'm using BibDesk (Mac) to "organize" my bibliography, although it seems pretty complicated for me (downloading JabRef didn't have any success due to Java 6, which is required and due to the bug that it could not find a "Java environment" for installation -- whatever this means).

  2. So, I pull my pdf-file (= paper) to BibDesk, enter all data (author, year, journal, etc.) and it pops up in my bibliography in Bibdesk. Then I do the "right mouse click" and press "Copy Bibtex code". Then I open a new texmaker file, paste it in there and save it as my bibliography.bib file.

  3. I did this for two papers so far (both in the same bib file), but I closed the Bibdesk after the first one and opened it a couple of hours later after a writing-break (maybe this is important!?)

  4. I kept on writing and cited with \citep{citekey}

  5. This works ONLY for the first paper, but not for the second one, although both are in the same bib-file.

  6. I tested, whether LaTex actually finds the second paper, by putting \nocite{*} one line above the \printbibliography. And here, the second paper is shown in the bibliography at the end of the document.

  7. I kept the \nocite and tried to cite the second one with \citep and \cite and \autocite. Neither of it worked out. There's not even a question mark, but simply nothing. It's like the \cite thing is not read by Latex for the second paper.

  8. I cited NOTHING and deleted the \nocite and still the bibliography at the end of the document shows my first paper, although not cited!!!???

I am working on this problem already 4h and read through almost the whole internet (including this site as well). However, I couldn't find a solution for my problem.

Here's my code (I have one main file; chapters are in separate files; and one file where all the format stuff etc. is written); only relevant stuff is shown, no content:

$a) Main-file:

%----------------------------------------------------------------------------------------
%   PACKAGES AND OTHER DOCUMENT CONFIGURATIONS
%----------------------------------------------------------------------------------------

\documentclass[
11pt, english,oneside
]{Thesis} % ... in this Thesis-file the basic stuff such as format, some packages etc. is stored) 

\usepackage[utf8]{inputenc} 
\usepackage[T1]{fontenc} 
\usepackage{palatino} 

\usepackage[backend=bibtex,style=authoryear,natbib=true]{biblatex} 

\usepackage{datetime}
\newdateformat{monthyeardate}{%
  \monthname[\THEMONTH], \THEYEAR}

\addbibresource{bibliography1} % this is my bib file

\usepackage[autostyle=true]{csquotes} 

\makeatletter

\newrobustcmd*{\parentexttrack}[1]{%
  \begingroup
  \blx@blxinit
  \blx@setsfcodes
  \blx@bibopenparen#1\blx@bibcloseparen
  \endgroup}

\AtEveryCite{%
  \let\parentext=\parentexttrack%
  \let\bibopenparen=\bibopenbracket%
  \let\bibcloseparen=\bibclosebracket}

\makeatother

%----------------------------------------------------------------------------------------
%   THESIS INFORMATION
%----------------------------------------------------------------------------------------

\thesistitle{Blabla} 

\begin{document}

\frontmatter

\pagestyle{plain} 

%----------------------------------------------------------------------------------------
%   THESIS CONTENT - CHAPTERS
%----------------------------------------------------------------------------------------

\mainmatter 

\pagestyle{thesis} 

\input{Chapters/1}
\input{Chapters/2} 
\input{Chapters/3}
\input{Chapters/4} 
\input{Chapters/5} 

%----------------------------------------------------------------------------------------
%   THESIS CONTENT - APPENDICES
%----------------------------------------------------------------------------------------

\appendix

\input{Appendices/AppendixA}
\input{Appendices/AppendixB}

%----------------------------------------------------------------------------------------
%   BIBLIOGRAPHY
%----------------------------------------------------------------------------------------

\printbibliography[heading=bibintoc]

%----------------------------------------------------------------------------------------

\end{document}  

b) Bibliography (bib-file):

@article{citekey1,
    Author = {Author names and names and names},
    Date-Added = {2015-11-07 17:11:58 +0000},
    Date-Modified = {2015-11-07 17:13:25 +0000},
    Journal = {Something here},
    Pages = {50-52},
    Title = {TestTest},
    Volume = {Volume 2},
    Year = {2000},
}

@article{citekey2,
    Author = {Author names and names},
    Date-Added = {2015-11-07 17:13:41 +0000},
    Date-Modified = {2015-11-07 17:14:45 +0000},
    Journal = {Something here},
    Pages = {100-103},
    Title = {Blabla},
    Volume = {Volume 3},
    Year = {2005},
}

c) Chapter 2 file (only the citations):

\ref{fig:picture1}. \begin{figure}[htbp]
\centering
\includegraphics[scale=.5]{picture1}
\caption{Describing the figure here and cited after \citep{citekey1}}
\label{fig:picture1}
\end{figure}

and the second part of the chapter 2 file:

\citep{citekey2}.

Only the first citation is shown in bibliography and cited in the text. The second one is neither shown in the bibliography nor is it cited by Latex. However, with the \nocite{*} command the second citation is then shown in bibliography. The first citation is always shown, even if it is not cited.

I also did the correct order (pdflatex, bibtex, 2x pdflatex) I am using Texmaker on a Mac.

Please, help me with this problem.

closed as unclear what you're asking by moewe, Kurt, Martin Schröder, Mico, Werner Nov 23 '15 at 23:16

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SE. I've taken the liberty of formatting your code a bit for improved readability. – Mico Nov 7 '15 at 20:00
  • 2
    Where does your used class Thesis comes from? Do you have a link for us? have you checked the bibliography error log in file *.blg? – Kurt Nov 7 '15 at 20:10
  • 1
    You shouldn't need to copy code into a separate .bib file. BibDesk manages your .bib database. You just add stuff to it and then use that database in e.g. \addbibresource{bibdeskdatabase.bib}. Right now, nobody can use your code to reproduce the problem. Please edit it so that we can reproduce the issue. This means no \input{<file we don't have>} and no class or packages which aren't standard. (If one of them is the problem, please provide a link.) – cfr Nov 8 '15 at 0:22
  • What to the .blg and .log files have to say about your problem? Is there any error or warning? Did you try a compilation from scratch will all temporary files erased? Have you checked your .bib file really contains all necessary citations and is well formed? If none of this gives you any hint to solving your problem, please try to narrow the problem down by creating an MWE. Right now we cannot even run the code your provide because of all those \inputs and Thesis.cls. – moewe Nov 8 '15 at 8:38
  • 1
    I have voted to close as unclear. The code should work and the OP has not responded to our questions, they have not been seen for two weeks. – moewe Nov 23 '15 at 22:27