0

RefTeX will no longer load my custom citations commands when using the lines from Setting up RefTeX with biblatex citation commands in my init file. Nothing changed in my init file, but it no longer loads the custom citations commands and only shows the default citation commands with C-c [.

Is there any reason for this? I am using Ubuntu, and the same init file loads correctly in Windows.

  • 2
    Well, presumably something has changed since it last worked, but I'm not sure how we're supposed to guess at this point. Are you implying that the only thing in your .emacs are those lines you've linked to? Are you suggesting that you error messages are given when you open Emacs? Are you saying that your init files are identical on your two OSes? – jon Nov 8 '15 at 3:12
  • Did you do an update on one of your systems? Did really nothing (however minute) change? – moewe Nov 8 '15 at 8:43
  • After trying to test this with other .tex files, I figured out that this is occurring for my document that is using \documentclass[man,12pt]{apa6}. The same document works properly on Windows. If I comment this line out and save the document, the document.el file in the 'auto' folder updates. When I reopen the document the custom commands return. So it appears to be some issue with how emacs and apa6 interact. – Lee Nov 9 '15 at 20:59
  • If I remove the lines "apa6" and "apa612" from (TeX-run-style-hooks) the problem goes away. Any time I save the document, these lines will reappear, recreating the problem. – Lee Nov 9 '15 at 21:08
  • I was able to fix the problem by disabling the line (setq TeX-auto-save t) in my init file, and deleting the auto directory created by AUCTeX. There appears to be an interaction with this command and the apa6 class. Only in Ubuntu, not in Windows. – Lee Nov 9 '15 at 21:32
0

There was some interaction between the apa6 style and the AUCTeX automatic file parsing when using emacs in Ubuntu that did not allow my custom citation commands to work.

I disabled (setq TeX-auto-save t) in my init.el and deleted the auto subdirectory in my working folder. Info about the disabled option can be found here: Automatic Parsing of TeX Files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.