2

I am trying to use the AMS article in LyX. I want my output to look like the following (note margins are the same for the entire paragraph and not all letters are capitalized):

enter image description here

Here is my source code:

 \begin{doublespace}

 \section{Introduction. AbCdEfGEEEEEEEEEEEEEEE EE EE EE}\end{doublespace}

However, here is what I have:

enter image description here

and here is the PDF:

enter image description here

The first 6 letters I typed were AbCdEf, yet they are all capitalized in my document. How can I edit this so that not all letters are capitalized (for each section and subsection)? I also don't want all the letters in the word "Introduction" to be capitalized, but LyX does this once I click "Section."

3

This is the default for the AMS article document class - sections are set in small caps. These defaults are set in what is called a layout (and stored in a .layout file). Layouts are available in the in the Resources/layouts subfolder of your LyX folder, if you want to take a gander. Specifically, the AMS article layout is available in amsart.layout.

If you wish to change parts of a layout, you can do so by means of a local layout. Follow Document > Settings... > Local Layout and add the following:

Format 49
Style Section
Align        Center
Font
  Series     Medium
  Shape      Default
  Size       Normal
EndFont
TocLevel 1
End

Style Section*
Align        Center
Font
  Series     Medium
  Shape      Default
  Size       Large
EndFont
End

The above updates the Section and Section* styles to use a Default shape (formerly SmallCaps). Note that this will only change the display within LyX, and not the PDF output generated via pdfLaTeX. For this you also need to change the way the \section and \section* titles are handled under the AMS class. Therefore, additionally add the following to your Document > Settings... > LaTeX preamble:

\makeatletter
\renewcommand{\section}{%
  \@startsection{section}
    {1}
    \z@
    {.7\linespacing \@plus \linespacing}
    {.5\linespacing}
    {\normalfont\centering}% \scshape
  }
\makeatother

The above preamble addition will change the font for both \section and \section* to be void of \scshape on the LaTeX side.

LyX input:

enter image description here

LaTeX output:

enter image description here

  • I edited the preamble. When I enter your code into the local layout, it says "layout is invalid." – The Substitute Nov 8 '15 at 6:47
  • @TheSubstitute: What version of LyX are you using? Perhaps try without the line "Format 49". – Werner Nov 8 '15 at 6:49
  • That worked! I am using 2.0. Now let me reread your answer and see what happens. Thanks in advance! – The Substitute Nov 8 '15 at 6:50
  • 1
    @TheSubstitute: LyX is currently on version 2.1.4. I'd suggest an upgrade, just because. – Werner Nov 8 '15 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.