3

I would like to start my equations numbering with (8.67), so I used \setcounter{chapter}{7} but using \setcounter{equation}{66} does not help. How can I start equations numbering within chapter from number different than 1?

Here is more code:

\documentclass[12pt, c5paper]{book}
\usepackage{latexsym}%symbole do \LaTeXe
\usepackage{amsmath}
\usepackage{chngcntr}
\usepackage{polski}
\usepackage[utf8]{inputenc}
\numberwithin{equation}{chapter}
\begin{document}

\setcounter{chapter}{7}
\setcounter{equation}{66}

\begin{equation} \label{eq1}
\frac{i_{k}}{i_{p}}=\frac{1}{1,02+0471\surd\bar{a}/K\surd\bar{l}}
\end{equation}

\end{document}
  • What does not help help mean? What is the result? \setcounter{chapter}{8} and \setcounter{equation}{66} works for me – user31729 Nov 8 '15 at 18:49
  • It means that I still get (8.1) instead of (8.67). – user2300369 Nov 8 '15 at 18:51
  • Show us more of your code then -- are you using \setcounter{chapter}{7} before \chapter{foo} and \setcounter{equation}{66} as well? – user31729 Nov 8 '15 at 18:51
  • I get (7.67), which is expected since chapter has the value of 7 then – user31729 Nov 8 '15 at 18:56
  • Recall that the \chapter command resets equation, so you have to say \setcounter{equation}{66} after issuing \chapter. – egreg Nov 8 '15 at 19:01
3

This should work: \setcounter{equation}{66} after \chapter{...} since \chapter usually resets the equation counter.

\documentclass{book}


\begin{document}
\setcounter{chapter}{7}
\chapter{foo}   % chapter steps to 8 and resets equation to 1

\setcounter{equation}{66}
\begin{equation}
  E = mc^2
\end{equation}
\end{document}
  • Setting \setcounter{chapter}{8} and omitting \chapter{foo} works too... – Mico Nov 8 '15 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.