1

I have read this topic and I did as suggested to get my reference in the superscript, but I am not fully pleased with the effect, because when I type in Nicholson and Shain\cite{Nicholson64}. I get my superscript number after the dot, not before. How to force it to be before the dot?

My minmal working example is:

\documentclass[12pt, c5paper]{book}
\usepackage[superscript, biblabel]{cite}
\let\oldthebibliography=\thebibliography
\let\oldendthebibliography=\endthebibliography
\renewenvironment{thebibliography}[1]{%
    \oldthebibliography{#1}%
    \setcounter{enumiv}{28}%
}{\oldendthebibliography}

\begin{document}

\ldots it was worked out by Nicholson and Shain \cite{Nicholson64}.

\bibliographystyle{ieeetr}
\bibliography{biblio}

\end{document}

and inside biblio.bib file I have:

@article{Nicholson64,
    journal = "Anal. Chem.",
    volume = "36",
    pages = "706",
    year = "1964",
    author = "R. S. Nicholson and I. Shain",
}
1

Just add the nomove option to cite:

\usepackage[superscript, biblabel, nomove]{cite}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.