9

I'm currently stuck at using a particular two column LaTeX style with multiple authors and two affiliations.

I want the author formatting to look like this: enter image description here

The style file is the following: http://acl2015.org/files/acl2015.sty

Minimal example for using the style guide:

\documentclass[11pt]{article}
\usepackage{acl2015}
\usepackage{times}
\usepackage{url}
\usepackage{latexsym}

\title{My title}
\date{}

\begin{document}
\maketitle
\begin{abstract}
  ..
\end{abstract}

\section{Credits}
...

\end{document}

I tried to use authblk to insert multiple authors but there seems to an error which doesn't allow me to produce a pdf anymore. To use authblk, I tried to use the code from https://tex.stackexchange.com/a/9598/8850

This results in the following code:

\documentclass[11pt]{article}
\usepackage{acl2015}
\usepackage{times}
\usepackage{url}
\usepackage{latexsym}
\usepackage{authblk}

\title{More than one Author with different Affiliations}
\author[*]{Author A}
\author[**]{Author B}
\author[*]{Author C}
\affil[*]{Department of Computer Science, \LaTeX\ University}
\affil[**]{Department of Mechanical Engineering, \LaTeX\ University}

\renewcommand\Authands{ and }
\date{}

\begin{document}
\maketitle
\begin{abstract}
  ..
\end{abstract}

\section{Credits}
...

\end{document}

Upon trying to compile the LaTeX code, I get the following error message:

("C:\Program Files\MiKTeX 2.9\tex\latex\psnfss\ot1ptm.fd")

! LaTeX Error: Something's wrong--perhaps a missing \item.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.21 \maketitle

? 

I guess there is a clash between the style file and authblk? I'm sorry for posting such a basic question, but I've wasted a couple of hours trying to get multiple affiliations and multiple authors running with this style.

(The code I posted above with separate the authors with commas. Is there a way to separate by a longer space, like in the image posted above?)

1 Answer 1

7

Try loading the authblk package before the acl2015 package.

Worked for me (I'm using acl2016 package and I was facing the same error you reported).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .