I want my bibliography list order to follow the order of the citation. That is, the citations should not have the bibitem order, whereas the bibitem's must follow the citations order. For instance, if I cite a book in my first page of my thesis, it should be the first item in the bibliography, and second cite must be in the second in the bibliography.

For example:


\bibitem  This has to be my second reference in my list.
\bibitem  This has to be my first reference in my list.


Feel free to edit this question. May be I am not conveying these things in a proper English.

  • Duplicate question – thewaywewalk Nov 11 '15 at 12:05
  • You can't use the thebiblibliography environment with biblatex. And if you want to use it, you will have to sort the bibitem manually. – Ulrike Fischer Nov 11 '15 at 12:34

Using biblatex is a very good idea but then you have to use a bib file.

The advantage is double: biblatex gives you a lot of parameters to define the layout of the bibliography and the bib file can be used for more than one LaTeX document.

You gave no concret examples for your book so have a look to this MWE (package filecontents is only used to include a example bib file in the mwe code; please notice that I used biber):

  author    = {Goossens, Michel and Mittelbach, Frank and 
               Samarin, Alexander},
  title     = {The LaTeX Companion},
  edition   = {1},
  publisher = {Addison-Wesley},
  location  = {Reading, Mass.},
  year      = {1994},
  title     = {The Restaurant at the End of the Universe},
  author    = {Douglas Adams},
  series    = {The Hitchhiker's Guide to the Galaxy},
  publisher = {Pan Macmillan},
  year      = {1980},
  author  = {Albert Einstein},
  title   = {{Zur Elektrodynamik bewegter Körper}. ({German}) 
             [{On} the electrodynamics of moving bodies]},
  journal = {Annalen der Physik},
  volume  = {322},
  number  = {10},
  pages   = {891--921},
  year    = {1905},
  DOI     = {http://dx.doi.org/10.1002/andp.19053221004},


\usepackage[utf8]{inputenc} %  <========================================
\usepackage[T1]{fontenc}    %

  backend=biber, % bibtex  % bibtex or biber (prefered)
  sorting=none  % none, nty % no sorting or standard sorting
\addbibresource{\jobname.bib} % calls bib file to create the bibliography

We first cite Albert Einstein~\cite{einstein}, second~\cite{adams} and 
third the \LaTeX{} Companian~\cite{goossens}.


With the option sorting=none the resulting bibliography follows your cites as you can see here:

enter image description here

Now only with changing the biblatex option sorting=nyt the resulting bibliography is sorted by the author names.
See here:

enter image description here

The order of the bib entrys in the bib file do not change the results.

Just a remark: You saw the character ö in my example bib file? That's the reason I used utf-8 encoding (line 35 of MWE). Then you should use biber, which can handle utf8 encoding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.