3

In WinEdt 8.0 the text within dollar signs $...$ in the .tex file was highlighted by using a different background color than the rest of the text. I installed WinEdt 9.0 and this effect is no longer there. I would like the background of the text within $...$ to be highlighted.

After some searching I found that I can manually change the highlighting in the Switches.ini file. I think I need to look at the following lines of code

SWITCH="$?$"
   ENABLED=1
   MODE_FILTER="TeX|DTX;INS;STY;AUX"
   START="$"
   STOP="$"
   HIGHLIGHT_START=1
   STEP_OVER_STOP=1
   HIGHLIGHT_STOP=1
   SCOPE=3
   DOMINANT_PRIORITY=0
   STRICT_PRIORITY=0
   PRIORITY=5
   INDENTED=0
   BOLN_ONLY=0
   CASE_SENSITIVE=1
   START1_TRIGGER=""
   START2_TRIGGER=""
   STOP1_TRIGGER=""
   STOP2_TRIGGER=""
          TEXT_COLOR="xclMath"
          DEFAULT_FONT=1
          ITALIC=1

When examining other switches, I come across these lines in the SWITCH = "$$?$$" part

   CUSTOM_BACKGROUND=1
   GRADIENT_BACKGROUND=256
   TRANSPARENT=128
   GRADIENT_COLOR="xclEnvBkLeftGradient"
   BACKGROUND_COLOR="xclEnvBk"    

However, adding these lines at the end of the code for the switch "$?$" changes nothing in the .tex file. What am I doing incorrectly?

Moreover, even changing the command ITALIC=1 to ITALIC=0 does not seem to change anything. Am I even looking in the correct place?

1

Add only BACKGROUND_COLOR="xclEnvBk" in the section of switches.ini. The rest of the setting from $$ are for multiline backgrounds. And don't forget to load the script.

enter image description here

| improve this answer | |
  • Great, thanks. I was unaware that I needed to load the script. – Ritz Nov 12 '15 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.