0

Using the package floatpag has made LateX ignore all my commands regarding the positioning of floats. For example, \begin{figure}[H] is not enforced anymore. Is there any get around with this?

I am using floatpag to suppress page-numbering of a specific float.

Sample code

\usepackage{float}
\usepackage{floatpag}
\floatpagestyle{plain}

\begin{figure}
\thisfloatpagestyle{empty}
... % a full page of subfigures
\end{figure}

\begin{figure}[H] %<-- this hold command is ignored
...

Note: [h!] does not work either.

  • your question asks about [H] (from float package) but your example fragment uses [h] (standard latex) Your question would be much easier to understand if the example was a complete document that demonstrated the problem (you can use \rule{3cm}{4cm} or whatever is needed in place of \includegraphics, to make it self contained) – David Carlisle Nov 12 '15 at 11:19
  • edited. I don't really know how to use \rule.. – Argyll Nov 12 '15 at 11:23
  • Just use it exactly as I showed, and it will make black rectangle of the stated size, which can represent an included image in the example. The code fragment even edited doesn't really help anyone debug. The example should be a complete document. But yes I just looked at floatpag.sty it is incompatible with float.sty so will disable [H] – David Carlisle Nov 12 '15 at 11:28
1

As a workaround try to change package loading order to:

\usepackage{floatpag}
\usepackage{float}

There are plans to do some code cleanup and make it compatible with float package in the next floatpag package release.

|improve this answer|||||
1

The \floatpagestyle{empty} command is designed to set the page style on float pages (as used by [p] floats). the package redefines float internals in a way incompatible with the float package so do not use them both together. In the case of [H] or [h] floats they are by definition on a text page not on a float page, so the command could do nothing in that case anyway. For a float forced to be "here" on a text page, just use \thispagestyle{empty} to set the page style of that page.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.