2

MikTeX comes with 69 languages preloaded as reported at compilation time:

This is XeTeX, Version 3.14159265-2.6-0.99992 (MiKTeX 2.9 64-bit) (preloaded format=xelatex 2015.11.9)  13 NOV 2015 10:35
entering extended mode
**PlasmaBook1.tex
("D:\Your files\KIA\OneDrive\PlasmaBook2\PlasmaBook1.tex"
LaTeX2e <2015/01/01> patch level 2
Babel <3.9m> and hyphenation patterns for 69 languages loaded.

I don't like this situation while cannot explain exactly why, perhaps, because in the past saving computer memory was a recommended practise.

I tried to remove unused languages though the MikTeX Options.

I unchecked most of languages on the Language tab: enter image description here

and rebuilt all formats:

enter image description here

Nothing has changed. At compilation time I still saw

Babel <3.9m> and hyphenation patterns for 69 languages loaded.

However running initexmf --dump from command prompt has actually removed unused languages. It seems that MikTeX Options has long-standing bug as was reported in Language (hyphenation patterns) not available 2 years ago.

A minor question is which of 4 hyphenation patterns for German language available in MiKTeX is recommended for users who (as me) load German pattern only to cite references.

2
  • 1
    With initexmf --dump you are building user formats which are stored in your user profile. With miktex settings (admin) you are changing and building admin formats. As user formats are found first they win. Use the user version of miktex settings to change and build them through a GUI. See also tex.stackexchange.com/questions/108447/… Nov 13 '15 at 8:06
  • @UlrikeFischer, please make an answer from your comment in order I could accept it. Nov 16 '15 at 6:38
3

With initexmf --dump you are building user formats which are stored in your user profile. With miktex settings (admin) (or initexmf --admin --dump) you are changing and building admin formats. As user formats are found first they win.

So use the user version of miktex settings to change and build them through a GUI. See also How should one maintain and update a MiKTeX installation?

3
  • It is somewhat strange. I always install new package and run MikTeX Options in admin modes. Why should I care about user's fmt? Why they appear at least? It's beyond any logics. Nov 16 '15 at 16:24
  • 1
    Well you did run initexmf --dump (and not initexmf --admin --dump) and so created user formats. Also it is possible that they appear on their own: After some updates the next pdflatex compilation can force the recreation of formats. Nov 16 '15 at 17:01
  • I usually launch MikTeX options from WinEdt 9 menu. It is tuned by default to use admin mode. How this behaviour could be changed? Nov 18 '15 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.