0

This question already has an answer here:

I'm getting a bitmap font on \mathbb{1} when I use the bbold package. After much searching on bitmap fonts specifically in relation to the bbold package, these articles are the closest I've got to a solution:

\mathbb{Z} is not displayed correctly

Image quality of pdf file generated from latex

However, they don't quite answer my problem. The best advice in the first is to use amssymb, which doesn't work in my particular case because amssymb renders \mathbb{1} as something else entirely (not a blackboard "1"). The second article is a bit general but does suggest the lmodern package, which still doesn't solve the problem.

Note also that I've already installed the cm-super font (using MiKTeX), as many other articles suggest.

Here's my code:

\documentclass{article}

\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{bbold}

\begin{document}

This is a test: $\mathbb{1}$.

\end{document}

Here's a fragment (the important bit) of the output:

Bitmap font on \mathbb{1}

As the image shows, only the \mathbb{1} is a problem.

marked as duplicate by egreg, Mensch, Przemysław Scherwentke, Zarko, Arun Debray Jun 5 '16 at 22:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Install bbold-type1: miktex.org/packages/bbold-type1 – egreg Nov 13 '15 at 23:09
  • Thanks for that. Though I should have explained that I've already installed that font (both the standard version and the type-1 version). – Paul Buckingham Nov 13 '15 at 23:13
  • 4
    Run updmap, see tex.stackexchange.com/questions/33608/… – egreg Nov 13 '15 at 23:15
  • That worked, thank you. I assumed refreshing the FNDB was enough after any install on MiKTeX—I didn't realize fonts required something else. – Paul Buckingham Nov 13 '15 at 23:26
  • I've seen several times this problem reported: MiKTeX doesn't update the font maps after installing font packages. – egreg Nov 13 '15 at 23:29

Browse other questions tagged or ask your own question.