2

I noticed that loading the navigatorpackage breaks my xeLaTeX documents if I use polyglossia as well.

%!TEX TS-program = XeLaTeX
\documentclass{article}
\usepackage{polyglossia}
\setmainlanguage[spelling=new]{german}
\usepackage{navigator}

\begin{document}

Hello!

\end{document}

XeLaTeX stops with

! Missing \endcsname inserted.
<to be read again> 
                   \baselineskip 
l.706 

Is there a way around?

  • 2
    Load navigator before setting the language. – egreg Nov 14 '15 at 19:24
3

The problem is that navigator doesn't take precautions against category code changes and uses in a couple of places ", which the German module of polyglossia makes active.

This of course confuses the macros and the result is the error you see.

Load navigator before setting languages and all should be OK.

\documentclass{article}

\usepackage{polyglossia}
\usepackage{navigator}

\setmainlanguage[spelling=new]{german}

\begin{document}

Hello!

\end{document}
  • egrep's answer is perfect when it is about German. Unfortunately, it breaks again when using russian as main or default language. I will investigate it and will share details if any. – Zimy May 22 '16 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.