1

I am working in Lyx and compiling a book layout. After each chapter an extra blank page appears. How can that extra page be removed?

\batchmode
\makeatletter
\def\input@path{{C:/Users/Anuja/Documents//}}
\makeatother
\documentclass[english,openany]{book}
\renewcommand{\familydefault}{\rmdefault}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{geometry}
\geometry{verbose,tmargin=1.5cm,bmargin=2.5cm,lmargin=2.5cm,rmargin=2.5cm}
\usepackage{setspace}
\usepackage{subscript}
\doublespacing

\makeatletter
\@ifundefined{date}{}{\date{}}
\makeatother

\usepackage{babel}
\begin{document}
\frontmatter


\title{\textbf{\huge{}Title}}

\maketitle

\chapter*{}


\chapter*{Acknowledgements}


\chapter*{Publications}


\chapter*{List of Figures}


\chapter*{List of Tables}
\end{document}
  • In book chapters always start on a right hand page, so you can get empty pages at end of chapters. This is intended, but if you prefer this not to happen, add openany to the customdocument class options in Document --> Settings --> Document class. – Torbjørn T. Nov 16 '15 at 16:39
  • Where is this option? I am not able to get it. – user87834 Nov 16 '15 at 16:57
  • Document --> Settings --> Document class. Under the heading Class options there is a text field called Custom. Type openany there. – Torbjørn T. Nov 16 '15 at 16:59
  • Thanks a lot the problem is solved. An extra page appears after the title as well. How can that be removed? – user87834 Nov 16 '15 at 17:02
  • No idea, don't think there should be one by default, so we need more information: try making a minimal working example, see wiki.lyx.org/FAQ/MinimalExample – Torbjørn T. Nov 16 '15 at 17:06
2

You have an empty chapter heading, i.e. the line saying \chapter*{}, the empty page actually contains that. Delete that one and you should be fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.