I am having a problem with my LaTeX output that is not printing the bibliography part. I am using Kile to code it. The strange thing is that, it was working out of the box before I reinstalled Ubuntu. After Ubuntu reinstallation, it does not work at all.

A minimal example added by Marco


author={John Smith},



Everybody should consider I have another file of biblioFile.bib in the same directory as my LaTeX source file.

  • You have to run bibtex. You can find it under View=>Compile=>bibtex or use the shortcut ALT+-. Commented Sep 8, 2011 at 15:43
  • For anyone to be able to help you, you need to supply a minimal working example (MWE) so that someone would be able to reproduce the problem. Otherwise, it would be virtually impossible to follow your technical footsteps and solve the problem.
    – Werner
    Commented Sep 8, 2011 at 15:44
  • I've run already using the quickbuild. My quickbuid setting is as follows: PdfLaTeX, PdfLaTeX, BibTeX, BibTeX, PdfLaTeX, PdfLaTeX.
    – alfa_80
    Commented Sep 8, 2011 at 15:46
  • @Shah: I edited your post. Now you have a minimal example. Does it work for you? Commented Sep 8, 2011 at 16:17
  • @Marco: It still doesn't work after trying the minimal example..it returns a single "?".
    – alfa_80
    Commented Sep 8, 2011 at 16:33

3 Answers 3


After running bibtex command, I encountered an error message as follows:

This is BibTeX, Version 0.99c (TeX Live 2009/Debian) The top-level auxiliary file: rr6.aux I couldn't open style file IEEEtran.bst ---line 4 of file rr6.aux : \bibstyle{IEEEtran : } I'm skipping whatever remains of this command I found no style file---while reading file rr6.aux 

This gave a clue to me, I was thinking there might be some missing packages..and after trying to search for "IEEEtran" keyword in the synaptic manager, I found "texlive-publishers" that could be related. After installing it, it turned out that it is again working :-)

Credit should go to Marco for guiding me to fix this. He has provided a very good troubleshooting procedure :-)


I had the same problem. Uninstalled and installed "texlive-publishers" as suggested above, and now the whole thing stopped to work! Most of my packages and fonts were removed and weren't re-installed. I had to spend 2 hours to see what is missing (texlive-extra packages, texlive recommended fonts, etc) to reset to the previous installation. Now I am back to something like the previous installation, but the error is still there : "I couln't open style file IEEEtr.bst". I changed the style file name to IEEEtran, called IEEEtran, and removed manually .aux file and it worked.

  • good to hear that :-)
    – alfa_80
    Commented Feb 14, 2012 at 10:26

I had exactly the same problem in Ubuntu with TexStudio. I downloaded the file IEEEtranS.bst from (http://tug.ctan.org/biblio/bibtex/contrib/IEEEtran/IEEEtranS.bst), and saved in the current directory with the name IEEEtran.bst, deleted old .aux files. Compiled and it worked for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .