2

I upgraded my Mac to the OS X EI Capitan a few days ago. And now TeXShop is not working. When I try to typeset it, the console shows the following error:

xelatex: command not found.

Following a previous answer, I went to Preferences-->Engine and changed the path of (pdf)TeX from
/usr/texbin
to
/Library/TeX/texbin

But the error was still the same.

Then, I also tried to change accordingly the path for the Distiller ghostscript from
/usr/local/bin
to
/Library/TeX/local/bin

But still, all remains the same.

How can I fix it?

1

I re-downloaded MacTex (from https://tug.org/mactex/mactex-download.html) and now it works. I checked the path under Preferences--»Engine and the distiller has now the same path I had manually inserted, namely: /Library/TeX/local/bin Thus, I still do not know why it did not work, but at least it does now;-)

0

Try changing the engine path to /usr/local/texlive/2015/bin/x86_64-darwin. It works for me, although I have tested it throughly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.