0

I am having the same issue as MarkSvalov in this post. Sadly it seems like it has been removed.

figure

The same thing is happening to the List of tables, but not to the listings (source code).

So what I am using is classicthesis.

I can just download the zip and build it with my TeXstudio and I'll get the exact same behaviour.

As I tried to cope with this issue for an hour now I already tested all the ctf pre and after commands. What I believe is that the word "figure" or "table" gets somehow into the section numbering.

If I take a look at the *.lof or *.lot file the content supports my findings:

\contentsline {figure}{\numberline {1{figure}}{\ignorespaces SomeFigure}{9}{figure.caption.9}

As you can see {1{figure}} doesn't seem right.

I am really happy with TeXstudio, but I'll try another environment to see if it'll still occur.

Do you guys have any idea how I can disable this behaviour?

I read somewhere that people had problems with the automatic language detection of their latex Editor/IDE and some package called bable.

But I couldn't find any settings that would support this idea.

Maybe you guys can help me. Thanks a lot in advance!

Best regards.

15
  • 1
    Welcome! Since this isn't the default behaviour, we cannot help without a small example of code we can copy-paste-compile to reproduce the problem. However, it has nothing to do with TeXStudio. That's just an editor. It doesn't compile anything and any other editor will use exactly the same software to compile your code, with just the same results. It doesn't have anything to do with babel either, if that's what you mean. (As in Babel Fish.)
    – cfr
    Nov 20, 2015 at 1:49
  • The package you mention is babel ( from the eponymous polyglot tower).
    – Bernard
    Nov 20, 2015 at 1:53
  • That is, we can only say to you what Kurt said there to MarkSvalov. Somewhere in your code is an error. Without the code, that's all we can say. Except that the error has to do with the writing of the .lot and .lof entries. But unless you want to correct those by hand, that's not much help.
    – cfr
    Nov 20, 2015 at 1:53
  • That was a typo. My bad. I meant babel. Nov 20, 2015 at 1:53
  • 2
    Update! your! Tex! distribution! now! tex.stackexchange.com/questions/269749/… If this doesn't fix your issue, please post the log file, especially the version of caption3.sty used.
    – user2574
    Nov 20, 2015 at 21:14

1 Answer 1

0

Alright, at least I figured out how to get rid of the issue, although I couldn't quite find the origin of it.

First of all thank you very much for your help @cfr .

As I tried to compile a fresh sample of classicthesis and the error still kept popping up, I switched to my linux distribution and successfully hit the pdflatex to create an error free version.

On Windows the error still occured with MikTex, so after that I completely wiped everything and reinstalled the environment. No error occurs. Even though I am using the exact same latex source files.

So what I'd suggest if you come across this problem, try to delete all the auto generated files, if it still doesn't help, test it in another environment (maybe you got a Virtual Machine laying around?).

Hope this helps.

Best regards.

Not the answer you're looking for? Browse other questions tagged .