0

I have a two columns document with several figures and in a certain part the page breaks in the middle of the right column, where two figures should be, and then the next page starts with an empty left column and the two figures on the right column.

I know that Latex places the floats where it seems convenient so I don't mind if the figures are moved beyond the part where I make a reference to them, but I do not want this empty space (most of the right column empty on one page and a left empty column on the next page).

Does somebody have an idea how to fix this?

So far I have tried with the \afterpage{\clearpage} command in several places and also put a \FloatBarrier in the next section.

I have also tried with the commands:

\renewcommand{\floatpagefraction}{.9}

\renewcommand{\topfraction}{.9}

to allow more floats in the page. None of this has worked so far.

I really appreciate any help on this.

  • Which options for the figure environment you use? it seems, that you use [H], and consequently the float is moved an the next column/page, if it has not enough place where you like to have and left empty space to its real placement. – Zarko Nov 20 '15 at 10:54
  • So far I have tried with !h and !t – StickBoy Nov 20 '15 at 11:28
  • Could you provide us with a minimal example from \documentclass to \end{document} which shows the problem? – Ignasi Nov 20 '15 at 11:47
  • may be you need to change this (default in book.cls) \setcounter{dbltopnumber}{2} \renewcommand\dbltopfraction{.7} \renewcommand\dblfloatpagefraction{.5} db for twocolumn. – touhami Nov 20 '15 at 12:31
  • without an example impossible to guess, but note if you use [!h] or [!t] they both restrict the places where the float can go, banning float columns, so \renewcommand{\floatpagefraction}{.9} will have no effect. (that setting itself is rather suspect as if you did allow floats to be placed on columns of just floats then that setting means it will only be allowed if the column is at least 90% full which is typically not possible unless the vertical size of the floats is just right to fit. You can use (eg) \rule{3cm}{4cm} instead of \includegraphics so the example is self-contained. – David Carlisle Nov 20 '15 at 14:57
1

It is very hard to guess what the problem is given the lack of information, but

\renewcommand{\floatpagefraction}{.9}

will typically make it impossible to make float pages: latex will hold floats back until it can fill at least 90% of the page, so if for example you have two floats that are 50% of the text height, it will not allow one (not enough of the page filled) and will not allow two (as no space to get both figures and the inter-figure separation)

However float pages will anyway be banned if you use [!h] and [!t] the first of those options should never be used as it gives latex almost no legal place to place the figures (normally it generates a warning that it is being changed to [!ht]) but [!t] is also very restrictive, its main effect is to ban floats from being at the bottom of the page or in a column of floats (as it does not include b or p)

In general (if you use the position option at all) you should not use ! and should include at least p in the position options.

  • Sorry for the very late reply. Your answered help me a lot. What I did to solve this is basically I removed the \newnewcommand, and started placing the figures one by one again, without the ! option and tried with different sizes until it worked. Thanks for the help! – StickBoy Feb 10 '16 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.