I'm using musixtex in xelatex, and there's a problem: command \breve is defined in musixtex and in "math mode" (is it a package "amsmath"?). So, I have a warning due compilation:

LaTeX Error: Command `\breve' already defined.

There is no \usepackage{amsmath} or \usepackage{amssymb} in document, but xelatex loads it himself (line from log):


How can I disable loading math packages or "math-mode"?

  • Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. Nov 23 '15 at 7:47
  • 2
    \breve is a math accent which is include in plain LaTeX, as well as in plain TeX. You can only disable it by rebuildung the format without it. Or you could just \let\breve=\relax before loading musixtex. Nov 23 '15 at 8:27
  • as Henri says you can "undefine" \breve but you are not correct that xetex automatically loads amsmath. You have not shown any information to guess what is loading it but either the class file or one of your othe packages. (the log would show, by matching the ( and ) around file names. Nov 23 '15 at 8:51
  • if \breve is "build-in" LaTeX command, amsmath doesn't matter. But it means, that musiaxtex developers are using a command, that's already used in base LaTeX, isn't it? So, I will always receive a message about "Command \breve already defined", becouse I can't disable \breve in base-latex, right?
    – Mike
    Nov 23 '15 at 9:39

The amsmath package is not loaded by default, but it's not the problem. You can just load fontspec with the no-math option:

%\usepackage{amsmath} % optional


No error about \breve is raised with or without amsmath and the definition of \breve in the document is the one by musixtex.

  • How to turn this global option off temporarily? Let's say I also want to write mathematics in between. How to disable it then?
    – Niranjan
    Jan 6 '20 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.