2

I am very new to LaTeX, and I'm trying to set up my citation and bibliography format. The only problem I have left is that my volume/issue is displayed in italics when I use the apacite bibliography style. How can I change this so that this is no longer in italics?

My text is as follows (I'm just trying things out for now):

\documentclass[12pt,a4paper]{thesis}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{apacite}
\usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
\usepackage[round]{natbib}

\author{Kristian Jensen}
\title{Bibliography in \LaTeX}
\begin{document}
\renewcommand{\BBAA}{and}  
\renewcommand{\BBAB}{and} 
\renewcommand{\BAnd}{and}


We are now going to try out how this works by doing a citation.

Here it is: \citep{Pressair}.

That's it for now.

\bibliographystyle{apacite}
\bibliography{mybib}

\end{document}

And from my mybib.bib file:

@Article{Pressair,
author = {Press, F., and Ewing, M.},
title = {Theory of aircoupled flexural waves},
journal = {Journal of Applied Physics},
volume = {22},
number = {7},
year = {1951},
pages = {892-899},
}

In my reference list now, everything looks OK except for the volume/issue which is displayed as 22(7) when I want it to be 22(7) (not italics). If anyone can help me fix this, then I will really appreciate it!

  • An aside: You shouldn't load the apacite and natbib packages independently. If you want to use natbib-style citation commands, you should load the apacite package with the option natbibapa (and, of course, not the natbib package as well). – Mico Nov 23 '15 at 10:34
  • Incidentally, there are lots and lots of document class files called thesis on the Internet. Which one would you happen to be using? – Mico Nov 23 '15 at 10:35
  • After fixing a problem in your bib file -- there should be no comma after "Press, F." in the author field -- I am unable to fully replicate the issue you say you're encountering. Specifically, the issue number is not set in italics, contrary to what you say is happening. – Mico Nov 23 '15 at 10:44
  • Hi. Thanks for your input! You are right - the issue number now appears to be correct, but the volume issue is still in italics. As for the 'natbibapa' suggestion, when I try to enter '\usepackage{natbibapa}' I get an error message that this file is not found (is there something else I have to enter?). Finally, I don't know which specific document class 'thesis' is. I just read that this one of the default styles (along with article, book, etc.). As I said, I'm very, very new to LaTeX, so I'm sorry if my questions are basic. – Kristian Nov 23 '15 at 10:56
  • 1
    Sorry for not beeing sufficiently clear. You need to load the apacite package with the option natbibapa as follows: \usepackage[natbibapa]{apacite}. (There is no package called natbibapa.) A separate note: If you don't want the volume number to be typeset in italics, you should consider not using the apacite bibliography style to begin with. – Mico Nov 23 '15 at 11:05
1

The apacite package contains a LaTeX macro that determines the default formatting of the journal, volume, number, and pages fields for entries of type @article. This macro is called \APACjournalVolNumPages, and its default definition may be found in apacite.sty starting at around line 1275.

To modify this macro, I suggest loading the etoolbox package and using that package's \patchcmd macro. Specifically, you should insert the following lines of code in the preamble, after having the loaded the apacite package:

\usepackage{etoolbox}
\makeatletter
\patchcmd{\APACjournalVolNumPages}%
    {\unskip, \Bem{#2}}%
    {\unskip, #2}{}{}
\makeatother

The macro \Bem is an alias for \emph. Basically, the modification of the \APACjournalVolNumPages macro consists in removing the italics emphasis of the second argument -- the contents of the volume field.

A full MWE:

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@Article{Pressair,
author =  {Press, F. and Ewing, M.},
title =   {Theory of aircoupled flexural waves},
journal = {Journal of Applied Physics},
volume =  {22},
number =  {7},
year =    {1951},
pages =   {892--899},
}
\end{filecontents}

\documentclass[12pt,a4paper]{article}
\usepackage[margin=2cm]{geometry}
\usepackage[utf8]{inputenc}
\usepackage{amsmath,amsfonts,amssymb}
\usepackage{graphicx}

\usepackage[natbibapa]{apacite} % load "apacite" with option "natbibapa" 
\bibliographystyle{apacite} % specify the bibliography style

\usepackage{etoolbox}
\makeatletter
\patchcmd{\APACjournalVolNumPages}%
    {\unskip, \Bem{#2}}%
    {\unskip, #2}{}{}
\makeatother

\AtBeginDocument{%
    \renewcommand{\BBAA}{and}
    \renewcommand{\BBAB}{and}
    \renewcommand{\BAnd}{and}}

\begin{document}


\citep{Pressair}

\bibliography{mybib}

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.