2

I just happened upon the strangest error with lualatex and polyglossia. I'm trying to compile a very easy file, here goes:

\documentclass[a4paper]{article}
\usepackage{polyglossia}
\begin{document}
\end{document}

and using the MiKTeX 2.9 rev.5238 with all the latest updates I receive the following error:

This is LuaTeX, Version beta-0.80.0 (MiKTeX 2.9) (rev 5238)
(./Main.tex
LaTeX2e <2015/01/01>
Babel <3.9l> and hyphenation patterns for 69 languages loaded.
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/article.cls"
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/size10.clo"))
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/polyglossia/polyglossia.sty"
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/etoolbox/etoolbox.sty")
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/makecmds/makecmds.sty")
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/xkeyval/xkeyval.sty"
("C:/Program Files (x86)/MiKTeX 2.9/tex/generic/xkeyval/xkeyval.tex"
("C:/Program Files (x86)/MiKTeX 2.9/tex/generic/xkeyval/xkvutils.tex"
("C:/Program Files (x86)/MiKTeX 2.9/tex/generic/xkeyval/keyval.tex"))))
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/fontspec/fontspec.sty"
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/l3kernel/expl3.sty"
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/l3kernel/expl3-code.tex")
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/l3kernel/l3unicode-data.def")
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/l3kernel/l3pdfmode.def"))
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/l3packages/xparse/xparse.sty")
("C:/Program Files (x86)/MiKTeX 2.9/tex/luatex/luaotfload/luaotfload.sty"
("C:/Program Files (x86)/MiKTeX 2.9/tex/luatex/luatexbase/luatexbase.sty"
("C:/Program Files (x86)/MiKTeX 2.9/tex/luatex/ctablestack/ctablestack.sty"
("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ltluatex.tex"
! Missing number, treated as zero.
<to be read again>
\relax
l.140 \newcatcodetable\catcodetable@initex

?
! Emergency stop.
<to be read again>
\relax
l.140 \newcatcodetable\catcodetable@initex

 264 words of node memory still in use:
    nodes
   avail lists: 2:6,3:3,6:2,9:2
!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on Main.log.

Any idea what could be wrong? I'm fresh out of ideas...

  • Do you have the latest updates? – Johannes_B Nov 24 '15 at 15:30
  • 1
    Your lualatex format is not current. – Ulrike Fischer Nov 24 '15 at 15:32
  • Your latex should be updated, although ltluatex is supposed to work on the older one (it isn't needed at all with current latex) so that error isn't really expected... – David Carlisle Nov 24 '15 at 15:44
2

You should upgrade your latex system then the problem would go, I don't recall that error but the only way that I can see it could occur is if \e@alloc@ccodetable@count has the incorrect definition (\relax most likely)

It should go if you add this \newcount line at line 140 of ltluatex.tex immediately before the existing line \e@alloc@ccodetable@count=\z@ so that the file looks like:

\newcount\e@alloc@ccodetable@count
\e@alloc@ccodetable@count=\z@
  • Freshly installed latest miktex version (64 bit) from their homepage and updated all the packages (now the updater reports no updatable packages found). The problem persists. Also tried adding above line to ./tex/latex/base/ltluatex.tex so that line 139 and 140 now read, respectively: \newcount\e@alloc@ccodetable@count \e@alloc@ccodetable@count=\z@ But also no good. :( Here is the log file: gist.github.com/zyrill/bfb1d851315b7256c309 – Meferdati Nov 25 '15 at 17:09
  • @Meferdati That log file shows LaTeX2e <2015/01/01> there have been 5 latex releases since then 2015/01/01 patch levels 1 and 2, then 2015/10/01 and patch levels 1 and 2 of that. I don't know in miktex how to force the formats to rebuild but I'll ask in chat..... – David Carlisle Nov 25 '15 at 17:30
  • @Meferdati: Make sure that you run the update manager in admin and user mode. Then recreate the formats in miktex -settings (admin). Make sure that xelatex and lualatex is not excluded in the format tab. If this doesn't change the format date, then you perhaps user format which you should update with the user miktex settings. – Ulrike Fischer Nov 25 '15 at 17:44
  • I ran the update manager in both admin and user mode (no updateable packages) and recreated all the formats after having made sure xetex, xelatex, luatex and lualatex were not excluded in the format tab (they were previously). It works now! Thx! Must have been the formats not having been updated before. Stupid not to include that by default. FYI: I undid the changes in ltluatex.tex. Still works. – Meferdati Nov 25 '15 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.