4

In an old document of mine, I used Hoefler (with XeTeX and MacTex) to get beautiful swashes at the end (and beginning) of lines of italic text.

Here's a screenshot (notice top line, end of the fourth, and last):

old document, beautiful swashes

For a new document, I wanted the same effect—but unfortunately, I don't seem to be able to recreate them.

Based on the old document, I tried with the following:

\documentclass[10pt]{article}
\usepackage{fontspec,xltxtra}
\defaultfontfeatures{Mapping=tex-text,Ligatures=Common}
\setmainfont{Hoefler Text}
\begin{document}
\noindent
\emph{House\\ Cat\\ Limerick}

Which results in this with no swashes:

no swashes

(Yes, I tried different variations in text; fontspec options; ligature parameters; even added full stops at the end. To no avail.)

I found an old reply to a similar question, with a working example of swashes—the final "e" in the italic text is typeset as I want it, but even modifying the example I can't reproduce it.

Surprised by all this, I then tried to recompile my own, working document: It runs fine, but the swashes are gone!

So now I have an (old) document and its PDF output which I don't seem to be able to reproduce. The only explanation I could think of is that sometime in the past couple of years, the default behaviour of some package changed from having "line-starting and line-ending swashes in italic Hoefler" from "default on" to "default off".

Without wanting to question this decision: How can I turn it back on? Any ideas what changed where (and why)?

Thanks, Nicola

EDIT:

Soon after posting, I figured out that I need to add Contextuals=WordFinal to the fontfeatures. (No, Contextuals=LineFinal won't do the trick…)

The only remaining issue is that—even though the documents gets typeset correctly (and beautifully)—I'm getting lots of error messages:

* fontspec warning: "aat-feature-not-exist-in-font"
*
* AAT feature 'Contextuals=WordFinal' (8,2) not available in font 'Hoefler
* Text/B'.

So if I don't add it, I get no error messages and no swashes; if I do add it I get error messages along with correctly typeset swashes. Is the error message incorrect? Or is it just being reported incorrectly?

6

The “contextual” feature must be explicitly turned on (if I remember correctly, it wasn't some time ago). What you get are warnings that the feature is not available for the upright fonts, but one can enable it just for the italic ones.

\documentclass[10pt]{article}
\usepackage{fontspec}
\setmainfont[
  Ligatures={Common, Rare},
  Alternate=1,
  ItalicFeatures={Contextuals=WordFinal},
  BoldItalicFeatures={Contextuals=WordFinal},
]{Hoefler Text}
\begin{document}

\noindent
\emph{House\\ Cat\\ Limerick}\\
\textbf{\emph{House\\ Cat\\ Limerick}}

\end{document}

enter image description here

No warning is issued to the console.

Avoid loading xltxtra: it adds nothing significant any more.

  • Yes, that must be it. Thank you! I am surprised of "if I remember correctly, it wasn't some time ago"—I always held TeX to its dictum that the same source would always produce the same output. And thanks for clarifying the error messages! – NicApicella Nov 25 '15 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.