1

I'm using chemnum. Conversion of EPS to PDF failed after a Windows updat:

! Package pdftex.def Error: File `file-pics.pdf' not found.See the pdftex.def package documentation for explanation.Type H <return> for immediate help.... \includeschemes{pictures/pic1.eps}

I've reinstalled MikTeX and TeXmaker and updated MikTeX's packages.

I apologyse for my big example. I minimized it.

EDIT

\documentclass[•]{article}
\usepackage{graphicx}
\usepackage[runs=2,crop=off]{auto-pst-pdf} 
  %eps mit pdflatex
%
\begin{document}
%
\includegraphics{5-FU.eps}
%
%
\end{document}

And here is the log:

 ------ LaTeX Warning: File `Latex_beispiel-pics.pdf' not found on input line 10.


! Package pdftex.def Error: File `Latex_beispiel-pics.pdf' not found.

See the pdftex.def package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.10 \includegraphics{5-FU.eps}

Using draft setting for this image.
Try typing  <return>  to proceed.
If that doesn't work, type  X <return>  to quit.


Package pst-pdf Warning: File `Latex_beispiel-pics.pdf' not found.
(pst-pdf)                Use the following commands to create it:
(pst-pdf)                ---------------------------------------------------- 
(pst-pdf)                latex Latex_beispiel.tex
(pst-pdf)                dvips -o Latex_beispiel-pics.ps Latex_beispiel.dvi
(pst-pdf)                ps2pdf Latex_beispiel-pics.ps
(pst-pdf)                ---------------------------------------------- .

When i compile with \usepackge{epstopdf} it works. without it doesn't. I have even tried to compile it the way it says in the .log: Latex->dvips->ps2pdf It still doesn't work. And I've found another strange thing. When I copy the file-pics.pdf from when it still worked, it deletes the .pdf with the pictures and puts out an error. I just don't get it anymore.

  • Welcome! It cannot find the file file-pics.pdf. Where is this file? Your document is using it, probably by including it using a package like graphicx or pdfpages. Try putting it in the same directory as you .tex file. – cfr Nov 27 '15 at 0:11
  • Thanks for the answer! The file-pics.pdf is in the same directory with the .tex file. The .eps files are in another directory. strangely everything worked just fine, until the update started. another strange thing ist, that the document compiles just fine on another pc, which also works with miktex and texmaker. – Murphy Nov 27 '15 at 0:18
  • Create the smallest document you can which produces the error. Then post the code for that together with the .log file. – cfr Nov 27 '15 at 0:24
  • I've copied the information you mistakenly posted in the answer space into your question. Please use the 'edit' link to add information when required. The answer space should be reserved for answers. However, to copy everything, I had to reduce the number of total characters. To do this, I edited your original question quite drastically. Please check that it still reflects your intentions. I deleted some stuff repeated in the new material and tried to condense the rest, but it was not easy to do this without losing anything. – cfr Nov 27 '15 at 2:40
  • 1
    Is that really the smallest document which produces the error? If you remove anything there, the error is resolved? If so, just remove the use of lipsum which you can't possibly need in your real document. – cfr Nov 27 '15 at 2:46
0
LaTeX Warning: File `*YourFilename*-pics.pdf' not found on input line ##

is most likely a failing in the auto-pst-pdf call via --shell-escape to perl or ghostscript

By default Tex Live for windows or mac may include minimal sets of these utilities.
However they are not normally installed with MiKTeX.

For the potential tests and solution see

https://tex.stackexchange.com/a/473106/170109

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.