2

I'm doing a long book with lots of figures and a few tables. I've put the \listoffigures and \listoftables tags in just after the \begin{document} tag but when I compile I get only the "List of Figures" and "List of Tables" titles and nothing listed. My header file has a lot of packages listed in it so I thought perhaps one of them might be causing the problem. So, I did a test with a short one-figure chapter in it and using the same header file so that I could eliminate packages until I found the offending one. To my surprise, it worked ... the packages that I'm using are not interfering. So, what might be the cause of the problem?

Here's the header file:

\RequirePackage[l2tabu, orthodox]{nag}
\documentclass[draft,12pt]{book}
\setlength{\parskip}{8pt}
\setlength{\parindent}{0pt}

% packages used
%\usepackage{geometry}
%\usepackage[margin=1in, paperwidth]{geometry}
\usepackage{color}
\usepackage{csquotes}
\usepackage{hhline}
\usepackage[arrowdel]{physics}
\usepackage{esint}
\usepackage{amssymb,amsfonts,amsbsy,textcomp}
\usepackage[letterpaper]{geometry}
\usepackage[pdftex,final]{graphicx}
\usepackage{makeidx}
\usepackage[table]{xcolor}
%\usepackage{supertabular}
\usepackage{tabu}
\usepackage{multicol}
\usepackage{microtype}
%\usepackage[utf8]{inputenc}
\usepackage{cleveref}
\usepackage[toc,page]{appendix}
\usepackage{biblatex}
\usepackage{float}
\usepackage[hang,flushmargin]{footmisc}
%\usepackage{showframe}

% aliases, new commands and macros here
%\newcommand\textsubscript[1]{\ensuremath{{}_{\text{#1}}}}
\newcommand\textstyleEmphasis[1]{\textit{#1}}
\newcommand\arraybslash{\let\\\@arraycr}
\newcommand\captionof[1]{\def\@captype{#1}\caption}
\newcommand\boldsubformula[1]{\text{\mathversion{bold}$#1$}}
\newcommand{\mop}[1]{\ensuremath{\mathbf{\hat #1}}}            %mop - matrix operator
\newcommand{\tens}[1]{\ensuremath{\mathbf{\overset{\sim} #1}}} %tens - tensor
\renewcommand{\familydefault}{\sfdefault}

\title{Essential Mathematics\\for NMR Spectroscopists}
\author{K.C. Brown\\Department of Chemistry\\University of Saskatchewan}
\date{\today\\[3pt]
Copyright \copyright\ K.C. Brown 2015}

\graphicspath{ {Figures/} }
\makeindex
\geometry{top=0.75in,left=0.80in,bottom=0.75in,right=0.80in}
\everymath{\displaystyle}

and here's the master file:

\include{header}

\begin{document}
\maketitle
\frontmatter
\include{preface}

\tableofcontents
\listoffigures
\listoftables

\mainmatter
\fontsize{12}{14}
%========================================[Complex Numbers]========================================
\include{ComplexNumbers}

%=========================================[Matrices]==============================================
\include{Matrices}

etc.

closed as unclear what you're asking by user31729, user13907, Henri Menke, lockstep, Rico Jan 1 '16 at 19:52

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Can you show one of the figure environments you have? By the way, remove \everymath{\displaystyle} which is utterly wrong and \fontsize{12}{14} that does nothing. Also \include{header} should by \input{header}. – egreg Nov 29 '15 at 15:30
  • Thanks egreg. I'm still very much a noob at Latex but learning more all the time. Here's an example figure:\begin{figure}[!h] \centering \includegraphics{Complex1} \caption{The Argand diagram.} \label{fig:Argand} \end{figure} – Keith Nov 29 '15 at 17:32
  • 2
    The lists of figures and tables are populated on the second LaTeX run, provided you don't remove auxiliary files. – egreg Nov 29 '15 at 19:03
  • Doesn't seem to matter how many runs I do .. no list of figures or tables, just the list titles. :( – Keith Nov 30 '15 at 16:50

Browse other questions tagged or ask your own question.