I am trying to use Latin Modern fonts in my document (using MikTeX in Windows 10, 64-bit). I have the following in my header:


When I compile, I get the following warnings/errors:

"C:Program Files\MiKTeX 2.9\tex\latex\lm\omxlmex.fd")[1

pdflatex.exe (file pdftex.map): cannot open font map file


A couple of lines (and overfull boxes) later it gets to

miktex-makemf: The ec-lmri source file could not be found

miktex-makepk: The application file ttf2pk.exe could not be found

And the final error, which reads:

!pdfTeX error: pdflatex.exe (file ec-lmri12): Font ec-lmri12 at 600 not found

==> Fatal error occurred, no output PDF produced!

I take all of this to mean that I am somehow missing Latin Modern roman italics at 12 points. How do I install it? And why did the lm package not install it?

1 Answer 1


I was able to fix my problem, thanks to Problems with fonts. This appears to be a MiKTeX bug, as stated in that answer by Bernard: "As happens from time to time, MiKTeX's installation of the fonts doesn't update the postcript fonts database, in particular psfonts.map and its friends."

The solution that worked for met was to run (from the command prompt), in order:

updmap --admin

initexmf --admin --mkmaps.

  • 4
    Your answer was useful for me, too, but I had to run initexmf --mkmaps as user, not as admin (I'll write it if someone else have the same problem of mine in the future), thank you!
    – CarLaTeX
    Commented Aug 19, 2016 at 5:34
  • dito, for me it also helped to run them as non-user (opening the console directly through MikTeX) - now it seems to work. thanks a lot!
    – LFH
    Commented Oct 30, 2018 at 13:37
  • initexmf --admin --mkmaps worked for me, thanks!!! Commented Dec 31, 2020 at 22:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .