1

I am having issues compiling in TeXShop since upgrading to El Capitan. I have searched extensively for a fix, but none of the recommended settings are fixing my problem. Here is a screenshot of my settings in TeXShop:

enter image description here

These settings produce the error: "/Library/TeX/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://www.tug.org/mactex/ and follow the instructions to (re)install MacTeX. A less likely possibility is that a tool path is incorrectly configured in TeXShop preferences. This can happen if you are using the macports or fink distributions."

Additionally, I already tried reinstalling MacTex to no effect. TeXShop is fully updated.


I tried compiled from the command line the simple document (named practice.tex):

\documentclass[12pt]{article}
\begin{document}
Hi
\end{document}

I tried /usr/local/texlive/2015/bin/*/pdflatex practice.tex and got:

This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded >format=pdflatex) restricted \write18 enabled. entering extended mode (/usr/local/texlive/2015/bin/x86_64-darwin/pdflatex LaTeX2e <2015/01/01> Babel <3.9l> and hyphenation patterns for 79 languages loaded.

! LaTeX Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation. Type H for immediate help. ...

l.1 ?

I then tried pdflatex practice.tex and got "command not found."

echo $PATH returns:

/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/usr/local/texlive/2012/bin/x86_64-darwin

kpsewhich -var TEXMFMAIN returns "command not found."

which pdflatex returns nothing.


ls -l /Library/TeX/texbin gives

total 8 lrwxr-xr-x 1 root wheel 29 Nov 29 21:48 texbin -> Distributions/Programs/texbin

ls /usr/local/texlive/2015/bin/ gives:

universal-darwin x86_64-darwin

  • You ought not need to change the settings if TeX Shop is updated. Are you using MacTeX 2015? You need the 2015 version of TeX Live. Earlier editions will not work. Please try compiling from the command line to see if that works. Try both /usr/local/texlive/2015/bin/*/pdflatex <tex file> and pdflatex <tex file> to make sure it works in both cases. echo $PATH would be useful, as would kpsewhich -var TEXMFMAIN and which pdflatex. – cfr Nov 30 '15 at 3:42
  • I tried typing in the things you suggest. I use command lines virtually never, so I put exactly what I did above, in case I did something incorrectly. The results are above. – Megan M. Dec 2 '15 at 21:28
  • Interesting. What does ls -l /Library/TeX/texbin give? And what does ls /usr/local/texlive/2015/bin/ give? – cfr Dec 2 '15 at 21:41
  • Put those in. See above. – Megan M. Dec 2 '15 at 21:45
  • Thanks. Sorry - I haven't used OS X for a while. Somebody on a Mac as they tried to help would be quicker as they wouldn't have to ask these questions :(. – cfr Dec 2 '15 at 23:54
1

In the end, a complete uninstall of MacTex worked. I followed the instructions here: https://tug.org/mactex/uninstalling.html, then reinstalled MacTex-2015. Everything compiles like it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.