0

I use win-7, 64 bit. I downloaded lyx bundle 2.1.4 packaged along with miktex 2.9. After installation, when I ran the program , a pop-up appears saying- 'lyx: no textclass found'. In detail, it tells- 'lyx will have only basic functionality because no text classes have been found. You can either try to reconfigure Lyx normally, try to reconfigure without checking your latex installation, or continue.'

Lyx opens after this but error messages like- 'document class not found' keep coming up. It seems I cannot save a document prepared on lyx on any format other than .lyx. Lyx itself seems to work properly. Math equation edits seem to function all right. But how do I save a document in a format other than .lyx? Please note that I am new to latex and do not know much yet.

In a lyx tutorial it says you can create PDF by going to document and then view. But the 'view' option in 'document' does not responds at all.

I have tried many things without success. I tried installing basic miktex 2.9 separately before lyx and I also tried installing previous stable versions of lyx. Nothing seems to work. Please help me get lyx working properly.

Edit: I tried reconfiguring but another error message turns up telling me to reconfigure again...

Thank you.

  • 1
    Did you reconfigure? It's in the Lyx menu Tools > Reconfigure – Deve Nov 30 '15 at 12:47
  • Yes. I tried that but no help. When i click reconfigure button in tools, another message comes up- 'the system reconfigure has failed. Default reconfiguration is used but lyx may not be able to work properly. Please reconfigure again if needed.' I try to reconfigure again but the same message comes up every time... Any idea whats wrong? – Prem kumar Dec 4 '15 at 19:15
  • 1
    I've often seen reports of this from Windows users. I'm still not sure why it occurs. I have never seen it on Ubuntu. – scottkosty Dec 4 '15 at 23:21
2

I battled for a complete day with this and could get nowhere, until I found what I believe is the problem. Here's what I did:

1) opened a command prompt in windows with administrative privileges.

2) navigated to the directory containing lyx.exe 'c:\program files (x86)\lyx 2.1\bin' on my machine.

3) executed lyx.exe

4) everything involving python calls failed - reconfigure (which uses configure.py), opening old documents (which uses lyx2lyx), etc.

5) exited lyx back to the command prompt

6) on the command line typed 'set pythonpath=' which clears the pythonpath.

7) on the command line typed 'set path=' which clears the path.

8) typed lyx.exe to reenter lyx

9) now everything works!

I'm not sure of all the pertinent information here, but I'm running windows 10 with a 64 bit python installation. I believe the lyx python calls are trying to run my python installation and not the one that comes with Lyx and here is the problem - the two are incompatible. By clearing the path and the pythonpath, it seems to force Lyx to find the python it installed and everything works.

I hope this helps someone and the Lyx developers.

  • Thanks for this answer! It would be great if you could test the newest LyX Windows installer (just released a couple of days ago) for LyX 2.2.2. Almost all the developers use Linux so we are always interested in input from Windows users to help fix bugs that we can't reproduce. If you're interested, we'd love to hear feedback on lyx-devel@lists.lyx.org, or for more user-related issues, lyx-users@lists.lyx.org. – scottkosty Nov 30 '16 at 17:44
  • Hi Scott: I did originally install Lyx 2.2 a while ago, and found that I had some problems working with old documents, so I decided to wait awhile. But in the last few days, I tried everything from 2.0 - 2.2.2 to no avail (slightly different problems, but in the end, could not make things work). I'm positive that I have this same problem with 2.2.2, but I don't now whether these instructions fix it with that version. – Pete P Nov 30 '16 at 18:11
  • dang I'm sorry to hear about the frustration. I hope that these bugs in LyX for Windows get ironed out. Thanks for the feedback. – scottkosty Nov 30 '16 at 20:55
1

I had this problem with Windows 7-64-bit, MikTeX 2.9 and LyX 2.3.2-2. None of the other answers worked for me. In the end it seems the reason may have been spaces in Windows paths. My observations follow below:

  1. Initially I had MikTeX installed in "C:\Program Files" and LyX in "C:\Program Files (x86)". The problem appeared.
  2. Uninstalling LyX and reinstalling in "C:\lyx" did not help. The problem remained.
  3. Uninstalled both LyX and MikTeX.
  4. Installed MikTeX in "C:\miktex".
  5. Installed LyX in "C:\lyx". Now LyX started and ran perfectly.

It may be enough to install MikTeX in a space-free path, I have not tested.

Unfortunately, there are lot's of programs that won't run correctly when installed in "C:\Program Files", but work fine in a path without spaces.

0

I had this problem today (Win 8.1-64 bit, Lyx 2.2.2.4), and eventually figured out how to make Lyx start (at least on my machine), so I'm sharing my solution in case it can help:

  • Open control panel/system/advanced (or something like that, my windows is localized).
  • Create an environment variable named LyxDir pointing to the Lyx installation folder. I choosed to create a system level variable, I suppose a user level one should do.
  • Now Lyx should start flawlessly.
  • In Lyx, under tools/preferences/paths you can see that "path prefix" makes use of this variable. It seems it had not been set by the installer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.