The "Open Recent" menu in TeXShop is not showing/recording any recent files.

open recent menu problem

Has anyone had (or heard of) this problem before? (Or better yet, know of a solution?)

The closest problem/solution I could find online was this. This person's problem was with Bibdesk (which I'm not using right now). I tried experimenting anyway with saving files with different encodings and/or changing the default encoding, but nothing has worked for me so far.

I have TeXShop 3.58 and recently upgraded to El Capitan. Everything else is working normally so far. No other application seems to have this problem, just TeXShop.

  • My Open Recent sometimes forgets some files as well. This is definitely TeXShop's fault if it is not OS X's. In both case you have tiny chance to get answer here. My guess is that OS X thinks it has multiple installations of TeXShop and hence has a hard time registering the recent files to the "current" version
    – Symbol 1
    Commented Dec 1, 2015 at 11:50
  • I started having the same problem after a TeXShop crash. Commented Nov 27, 2016 at 17:54

4 Answers 4



defaults write TeXShop NSRecentDocumentsLimit 10

to set the limit at 10 recent edits.

  • I have the same problem but this solution does not work. I tried this before and after updating TeXShop version. Commented Nov 27, 2016 at 17:53

I now suspect this is a larger MacOS issue as it co-occurs with other file and directory weirdness such as the "Favorites" items disappearing from the left nav of open/save windows. When I reboot the problem goes away.


A partial answer is suggested by a thread over at Apple (relevant post below). It's only partial because I'm not sure I have the correct code for TeXShop and hope someone more expert in MacOS/Unix can offer suggestions. The puzzle for me is what text should appear in the "company" portion of the suggestion like com.apple.textedit below. I entered variations of the following in the Terminal app and, after rebooting, my Open Recent submenu was working with 10 items:

defaults write edu.uoregon.texshop NSRecentDocumentsLimit 10

Can someone suggest the better code for this?

From Apple's tech support boards:


IIRC, you have to set that within each application, using this Terminal command:

defaults write com.XXXX."name of app" NSRecentDocumentsLimit YYY

where XXX = company, "name of app" = self explanatory, and YYY is the desired > integer value. E.g., for TextEdit, I used:

defaults write com.apple.textedit NSRecentDocumentsLimit 30

Relaunching TextEdit and you'll see File->Open Recent->shows last 30 opened documents.

  • 1
    I tried to use this method to increase the recent items, but it didn't work.
    – jhabbott
    Commented May 21, 2016 at 20:42
  • 1
    Try using defaults write TeXShop NSRecentDocumentsLimit 30 since the TeXShop Preferences file is called TeXShop.plist. Commented Nov 27, 2016 at 23:46

Instead of writing a command in the command line, I was able to fix the problem by going to "System Preferences", the "General". There is a "Recent items" option that you can set.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .