0

I am using Mendeley to compile my references and papers. I export automatically a .bib file for the folder in question and it appears and updates seemingly perfectly.

However, with a List/TOC--->BibTex Bibliography--->MyBIBFile.bib inserted some of the papers just don't seem to show up when I try to add the citations. Sometimes they appear, sometimes they disappear. Some are constantly working and never give problems.

When I open the .bib files in question in JabRef the articles not appearing are highlighted peach/red on the left hand side with respect to the number they are. Not quite sure how to remedy that or whether it would make a difference but I doubt it is co-incidence.

closed as off-topic by Werner, user13907, Mensch, Zarko, Martin Schröder Dec 1 '15 at 6:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Werner, Community, Mensch, Zarko, Martin Schröder
If this question can be reworded to fit the rules in the help center, please edit the question.

  • In JabRef, certain things are required, otherwise the entry is highlighted. For example, you need an author if it's an article or a book. The entries you mention that are highlighted, are they missing some content? – Werner Nov 30 '15 at 23:06
  • Can you please make a minimal example (.bib and .lyx files, they are just text so you can copy/paste them into code here): wiki.lyx.org/FAQ/MinimalExample – scottkosty Nov 30 '15 at 23:35
2

Solved on my own. There was a discrepancy in some of the actual authors names and the bibtexkeys which were generated for the .bib file exported from Menedeley Desktop..... so I thought they were not showing.

Not the answer you're looking for? Browse other questions tagged or ask your own question.