1

I can't seem to make these two packages play well. Is there a fix or should I just give up on it? Here is a MWE.

\documentclass[oneside]{amsart}
\usepackage{MnSymbol}
\usepackage[frenchmath]{mathastext}
\begin{document}
Equation.
\begin{align*}
    \left( \bigoplus_i Z_i \right)
\end{align*} 
\end{document}

What ends up happening is that all big brackets become ].

I should say that this comes from my fixation of have having math text upright (plus the fact that documents should be uploadable to the arxiv). For a long time I used kpfonts, which was excellent, but I kind of got bored of the font.

  • Try loading the packages in the reverse order: mathastext first. – Steven B. Segletes Dec 2 '15 at 15:37
  • hah, it worked! – pro Dec 2 '15 at 15:41
  • option noparenthesis would have excluded ( ) [ ] / from the scope of mathatext. (check the pdf doc for more excluding options). There is also option basic to limit its action to only letters and digits. – user4686 Dec 2 '15 at 16:32
3

As noted in my comment, reversing the order of package load (mathastext prior to MnSymbol) fixes the issue, giving both upright math variables as well as the MnSymbol paren delimiters and \bigoplus

\documentclass[oneside]{amsart}
\usepackage[frenchmath]{mathastext}
\usepackage{MnSymbol}
\begin{document}
Equation.
\begin{align*}
    \left( \bigoplus_i Z_i \right)
\end{align*} 
\end{document}

enter image description here

For comparison, here it is without MnSymbol:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.