1

I seem to not be able to get the following style for my pages (printed two-sided A4, the "Front" represents the face that faces the reader by default) with the \documentclass[twocolumn]{article}:

enter image description here

Thanks for helping me out!

1
  • The margins can easily be set up with the geometry package or one of those KOMA inducing classes. You can align a background to the text area using the background package, or using everypage and tikzpagenodes. Dec 2, 2015 at 16:29

1 Answer 1

2

Load the geometry package to set the margins. The border for the text area can be inserted using package scrlayer-scrpage.

\documentclass{book}
\usepackage[margin=5mm,inner=15mm]{geometry}

\usepackage{scrlayer-scrpage}
\DeclareNewLayer[
  background,
  textarea,
  addhoffset=-\fboxrule,
  addvoffset=-\fboxrule,
  addwidth=2\fboxrule,
  addheight=2\fboxrule,
  contents={%
    \fbox{\parbox[c][\dimexpr\layerheight-2\fboxsep-2\fboxrule\relax]
      {\dimexpr\layerwidth-2\fboxsep-2\fboxrule\relax}{\strut}}%
  }
]{border}
\AddLayersToPageStyle{@everystyle@}{border}

\usepackage{blindtext}% only for dummy text
\begin{document}
\blinddocument
\end{document}
2
  • Hey, tried your code. I get an errors: There are several problems at this line: -Package scrbase Error: unknown option ` addhoffset=-\fboxrule '. ]{border} (followed by: ) -Package scrbase Error: unknown option ` addvoffset=-\fboxrule '. ]{border} (followed by: ) -Package scrbase Error: unknown option ` addwidth=2\fboxrule '. ]{border} (followed by: ) -Package scrbase Error: unknown option ` addheight=2\fboxrule '. ]{border} (followed by: ) Dec 2, 2015 at 21:50
  • These options were introduced in KOMA-Script Version 3.16. Current version on CTAN and in MiKTeX and TL2015 is 3.19a. So you have to update your distribution.
    – esdd
    Dec 2, 2015 at 23:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .