2

I'm writing a presentation with Org-mode + beamer. I'm trying to include a picture but when exporting to 'PDF (Beamer)' with C-c C-e l P combo, the pdf isn't produced. I get this error msg: "org-latex-compile: PDF file ./ppt.pdf wasn't produced: Runaway argument". Also, if I click on the image link with the mouse I get: "Type C-c C-c to view the image as an image. Cannot display image: (Cannot determine image type)"

This is a MWE for ppt.org. Can you help me spot the mistake and correct it?

#+startup: beamer
#+LaTeX_CLASS: beamer
#+LaTeX_CLASS_OPTIONS: [presentation, smaller]
#+BEAMER_FRAME_LEVEL: 2
#+BEAMER_THEME: CambridgeUS
#+BEAMER_FONT_THEME: structurebold
#+BEAMER_ENV:
#+COLUMNS: %45ITEM %10BEAMER_ENV(Env) %10BEAMER_ACT(Act) %4BEAMER_COL(Col) %8BEAMER_OPT(Opt)
#+OPTIONS: H:2 toc:t email:n |:t
#+BEAMER_HEADER: \frenchspacing
#+BEAMER_HEADER: \graphicspath{{./IMGs/}}
#+TITLE: presentation
#+AUTHOR:
#+DATE: Dec 2015


* Intro
** What are CNTs?
*** when? who?                            :BMCOL:
    :PROPERTIES:
    :BEAMER_env: block
    :BEAMER_col: 0.57
    :END:
- 1952 bla bla bla
- 1991 Dr. Sumio Iijima publishes ``Helical microtubules of graphitic carbon'' 
*** second column                     :B_ignoreheading:BMCOL:
    :PROPERTIES:
    :BEAMER_env: ignoreheading
    :BEAMER_col: 0.24
    :END:
    #+ATTR_LATEX: width=\textwidth
    [[./IMGs/sumioIjima.jpg]]
  • If I investigate the .tex file and compile that with pdflatex I get "ERROR: File ended while scanning use of \beamer@collect@@body.". This is strange because yesterday, one of the compilations went well and I was able to open the pdf and see the picture that I'm trying to include. – WobblyWindows Dec 3 '15 at 11:49
  • I managed to root out the error -- a couple of environments in the .tex file weren't closed properly. Also when the tex file is generated, [[file.jpg]] is not automatically inserted into a figure environment. Why is that? – WobblyWindows Dec 3 '15 at 18:23
2

Using your code I have trouble with the ignoreheading option. A way to solve this is to write:

#+startup: beamer
#+LaTeX_CLASS: beamer
#+LaTeX_CLASS_OPTIONS: [presentation, smaller]
#+BEAMER_FRAME_LEVEL: 2
#+BEAMER_THEME: CambridgeUS
#+BEAMER_FONT_THEME: structurebold
#+BEAMER_ENV:
#+COLUMNS: %45ITEM %10BEAMER_ENV(Env) %10BEAMER_ACT(Act) %4BEAMER_COL(Col) %8BEAMER_OPT(Opt)
#+OPTIONS: H:2 toc:t email:n |:t
#+BEAMER_HEADER: \frenchspacing
#+BEAMER_HEADER: \graphicspath{{./IMGs/}}
#+TITLE: presentation
#+AUTHOR:
#+DATE: Dec 2015


* Intro
** What are CNTs?
*** when? who?                                :BMCOL:
    :PROPERTIES:
    :BEAMER_env: block
    :BEAMER_col: 0.6
    :END:
- 1952 bla bla bla
- 1991 Dr. Sumio Iijima publishes ``Helical microtubules of graphitic carbon'' 
*** second column                       :B_ignoreheading:
    :PROPERTIES:
    :BEAMER_env: block
    :BEAMER_col: 0.4
    :END:      
    #+ATTR_LATEX: width=\textwidth
    [[./tmp.jpg]]

So you avoid using :BEAMER_env: ignoreheading and have as output:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.