I installed MiKTeX and TeXnic-Center. I then installed the typesetting of my university (here: http://tubslatex.ejoerns.de/#releases).

I then compiled the .cls-file of the template from the institute with TeXnic(www.winfo.tu-bs.de/hp/upload/vorlagen/ds_latex_seminar.zip). At this point the following warnings and errors appeared:

  • "You have requested package ', but the package providesunitext'"
  • Command \@ already defined
  • Missing \bein{document}
  • Missing number, treated as zero
  • You already have nine parameters
  • Command \@already definied. Or name \end... illegal
  • Font shape /cmr/m/n' undefined using/cmr/m/n instead on input line
  • The font size ommand \normalsize is not defined
  • [...]

When trying to preview the unitext.dvi with the app YAP the following error message appeared: "Not loadable Fonts: ec-lmr12, ec-lmssbx10, ec-lmss12, ec-lcssby19"

"Not loadable Fonts: ec-lmr12, ec-lmssbx10, ec-lmss12, ec-lcssby19"

Here is what I have already tried:

1) I installed the typesetting of the university (see above) manually (meaning I put the folders of the TDS-archive in the right places) and automatically.

2) I used the MiKTeX-Packagemanager to install all(!) packages including the following strings: "lm". I understand that "lm" means latin modern.

3) I used the command (in admin mode): "initexmf --mkmaps"

4) I used the command (in admin mode): "updmap ec-lmr12.tfm".

The first time this command seemed to work (didn't return error message in the console), but it didn't solve the problem that the fonts are not loading.

Second time: After deinstalling everything and doing it all over again the following error message was returned by the console:

"log4cxx: No appender could be found for logger . log4cxx: Please initialize the log4cxx system properly. Sorry, but the "MiKTeX Fontmap Maintenance Utility did not succeed for the following reason: This utility does not accept non-option arguments. [...]" enter image description here

Do you have any idea why the fonts are still not loading? I already tried so much and it is still not working, so I would appreciate your help very much!

  • 1
    Welcome! What does the command kpsewhich ec-lmr12.tfm return? You'll need to get a command line prompt to run this. If that gives you the location of the file, it is likely that you need to run updmap as yourself and/or with admin rights. MiKTeX doesn't always update the font maps when new font packages are installed. – cfr Dec 4 '15 at 20:49
  • The command <kpsewhich ec-lmr12.tfm> returns the location of the file. I then used the command <updmap ec-lmr12.tfm> which seemed to work. There was a lot of output, ending with "updmap: Updating Is-R files". However, when viewing the .dvi file with the Yap-viewer the error message is still appearing as before. Still, four fonts are not loadable. But thank you really much for your help and time! – user5569792 Dec 4 '15 at 21:20
  • 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.