2

I did not find a journal for the paper I have cited from. Therefor I want to add an URL of the article entry in the bibliography. I have already added it but I am getting for this note (accessed on Nov. 6th, 2015} in the article entry without space between the words.

Is it possible to add some spaces between the words in the note? Please see the screenshot below.

enter image description here

tex code

\documentclass[
    11pt,
    english,
    twoside,
    a4paper,
    headsepline,
    footsepline
]{scrbook}

\usepackage{a4}   
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{cite}
\usepackage{color}
\usepackage[bookmarks=true,
            bookmarksopen=true,
            bookmarksnumbered=true,
            colorlinks=true,
            citecolor=black,
            linkcolor=black                 
            ]
            {hyperref}

\begin{document}

Mowing down trees, flooding streets and battering buildings, Patricia hit land as a Category 5 hurricane on Friday \cite{recordingData2} evening before grinding inland. It moved quickly but lost power in the mountains that rise up along the Pacific coast and was downgraded to a tropical depression on Saturday morning as it \cite{waze} headed through central Mexico \cite{recordingData}.

        \bibliographystyle{plainurl}
        \bibliography{bibliography}

\end{document}

bibliography.bib

@article{recordingData2,
  author = {Leon Stenneth and Ouri Wolfson and Philip S. Yu and Bo Xu},
  title = {Transportation Mode Detection using Mobile Phones and GIS Information},
journal = {ACM DL},
  year = {2011},
    pages = {3}
}

     @misc{waze,
         author = {androidcommunity.com},
         title = {Waze traffic app updates with Foursquare and Yelp integration},
         howpublished = {\url{http://androidcommunity.com/waze-traffic-app-updates-with-foursquare-and-yelp-integration-20120131/}},
  note = {Accessed: 29.09.2015}
}

@article{recordingData,
  author = {Rudolf Giffinger},
  title = {Smart cities Ranking of European medium-sized cities},
  journal = {Report of Centre of Regional Science},
  year = {October 2007},
  url  = {http://www.smart-cities.eu/download/smart_cities_final_report.pdf (accessed on Nov. 6th, 2015},
  pages = {11}
}
5
  • The options for document class or packages use […], not […].
    – Bernard
    Dec 5 '15 at 16:56
  • @Bernard: Sorry but I did not understand your comment. Where Have I to use it?
    – TheBook
    Dec 5 '15 at 16:58
  • You have, say, \usepackage\[T1\]{fontenc} instead of \usepackage[T1]{fontenc}, and a lot of such syntax errors.
    – Bernard
    Dec 5 '15 at 17:01
  • @Bernard: Also in my original file I have them as your correction I do not how these errors appear in the syntax. But this does not solve the problem.
    – TheBook
    Dec 5 '15 at 17:13
  • @TheBook The backslashes appeared because you hit the wrong button before the {} one. Never mind. I'd simply use a note field with the URL and the accession date.
    – egreg
    Dec 5 '15 at 17:15
2

There are several issues with your bib entries:

  • Do keep the information that belongs to year and month fields separate.

  • Likewise, don't amalgamate the contents of url and note fields.

  • Don't neglect to encase words that shouldn't be lower-cased -- such as "European", "GIS", "Yelp", and "Foursquare" -- in curly braces.

  • Do load the url package explicitly, and specify the option hyphens when loading the package so that long url strings can be line-broken at dash characters.

A separate matter: I think the entry recordingData contains several additional errors. First, you probably shouldn't use the entry type @article, as the publication does not appear to satisfy the usual criteria for a journal article. Do look into whether the @techreport entry type is more suitable. Second, the report has quite a few authors, not just Rudolf Giffinger. What are you trying to achieve by omitting the names of five of the six authors? Third, what is the field pages = {11} about? According to the link you provide, the report contains 28 pages rather than 11.

Giving off the impression of being cavalier or, worse, careless about the correctness of the entries in bibliography section is not a good way to engender a reader's trust in the correctness of the remainder of your paper or report.

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{bibliography.bib}
@article{recordingData2,
  author = {Leon Stenneth and Ouri Wolfson and Philip S. Yu and Bo Xu},
  title = {Transportation Mode Detection using Mobile Phones and {GIS} Information},
  journal = {ACM DL},
  year = {2011},
  pages = {3},
} 
@misc{waze,
   author = {androidcommunity.com},
   title = {Waze traffic app updates with {Foursquare} and {Yelp} integration},
   howpublished = {\url{http://androidcommunity.com/waze-traffic-app-updates-with-foursquare-and-yelp-integration-20120131/}},
   note = {Accessed: 29.09.2015}
}
@article{recordingData,
  author = {Rudolf Giffinger},
  title = {Smart cities Ranking of {European} medium-sized cities},
  journal = {Report of Centre of Regional Science},
  year = 2007,
  month = "October",
  url  = {http://www.smart-cities.eu/download/smart_cities_final_report.pdf},
  note = "Accessed: Nov.~6, 2015",
  pages = {11}
}
\end{filecontents}

\documentclass[
    11pt,english,twoside,a4paper,headsepline,footsepline
    ]{scrbook}

%%\usepackage{a4}   
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{cite}
\usepackage{color}
\usepackage[hyphens]{url}
\usepackage[bookmarks=true,bookmarksopen=true,
           bookmarksnumbered=true,
           colorlinks=true,citecolor=black,linkcolor=black                 
           ]{hyperref}

\begin{document}

        \nocite{*}
        \bibliographystyle{plainurl}
        \bibliography{bibliography}

\end{document}
2
  • Is there anyway to keep the citation in the document successive? I have used before "\bibliographystyle{ieeetr}" but I could not display the url in the article entry. Therefor I changed the style to \bibliographystyle{plainurl} but it does not keep the order of citation through the pages. Currently I am getting 3,1,2 and I want the order to be 1,2,3
    – TheBook
    Dec 5 '15 at 17:32
  • @TheBook - Not sure I understand the term "successive". Are you asking how to go about have the ordering of the entries in the bibliography be the same as their citation order? If so, you may want to give the unsrtnat bibliography style a try; if you go this route, don't load the cite citation management package, and do load the natbib citation management package. The ieeetr style, by the way, is well more than 20 years old by now; as it dates to an era from before the Internet (and having bib resources online), it's not surprising that it doesn't know what to do with URLs.
    – Mico
    Dec 5 '15 at 17:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.