2

I have use the \bibliographystyle{ieeetr} before as style for my Bibliography but when I wanted to add URL to the article entry, The ieeetr style did not recognize the URL. Therefore I changed the style to plainurl where I have lost the option to keep the citation number in the document incremented consecutively. Is there anyway to reach both option in one style or to fix it?

Currently I am getting t in the document this sequence of the citation number 3,1,2 and I want to get 1,2,3.

tex code

\RequirePackage{filecontents}
\begin{filecontents}{bibliography.bib}
@article{recordingData2,
  author = {Leon Stenneth and Ouri Wolfson and Philip S. Yu and Bo Xu},
  title = {Transportation Mode Detection using Mobile Phones and {GIS} Information},
  journal = {ACM DL},
  year = {2011},
  pages = {3},
} 
@misc{waze,
   author = {androidcommunity.com},
   title = {Waze traffic app updates with {Foursquare} and {Yelp} integration},
   howpublished = {\url{http://androidcommunity.com/waze-traffic-app-updates-with-foursquare-and-yelp-integration-20120131/}},
   note = {Accessed: 29.09.2015}
}
@article{recordingData,
  author = {Rudolf Giffinger},
  title = {Smart cities Ranking of {European} medium-sized cities},
  journal = {Report of Centre of Regional Science},
  year = 2007,
  month = "October",
  url  = {http://www.smart-cities.eu/download/smart_cities_final_report.pdf},
  note = "Accessed: Nov.~6, 2015",
  pages = {11}
}
\end{filecontents}

\documentclass[
    11pt,english,twoside,a4paper,headsepline,footsepline
    ]{scrbook}

%%\usepackage{a4}   
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{cite}
\usepackage{color}
\usepackage[hyphens]{url}
\usepackage[bookmarks=true,bookmarksopen=true,
           bookmarksnumbered=true,
           colorlinks=true,citecolor=black,linkcolor=black                 
           ]{hyperref}

\begin{document}

        \cite{recordingData2}, \cite{waze}, \cite{recordingData}
        \bibliographystyle{plainurl}
        \bibliography{bibliography}

\end{document}
2

I suggest you make two changes:

  • Don't load the cite package; instead, load the natbib package with the option numbers (since you appear to use numeric citation call-outs):

    \usepackage[numbers]{natbib}
    
  • Use the unsrtnat bibliography style instead of the plainurl style:

    \bibliographystyle{unsrtnat}
    

After making these modifications, be sure to run LaTeX, BibTeX, and LaTeX twice more to fully propagate all changes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.