3

In a double-spaced article, I'm trying to keep the \thanks note single-spaced. I use this topic to change the spacing of \thanks back to single-spacing. This works, but it also generates an empty line at the start of the note. How do I get the text to start on the same line as the * symbol?

\documentclass{article} 
\usepackage[doublespacing]{setspace}
\usepackage{lipsum}

\begin{document}

\title{\vspace{-4cm}Title goes here}
\author{Author Goes Here\thanks{\protect\singlespacing\protect\lipsum[1]}}
\date{\today}

\maketitle

\begin{abstract}
\noindent \lipsum[2]
\end{abstract}

\section{First section}
\lipsum[5]

\end{document}
3
  • I achieve single spacing without the use of \protect\singlespacing in \thanks.
    – Werner
    Dec 7, 2015 at 4:38
  • You're right. It must be one of the other packages I'm loading in the actual file that causes the odd behaviour. Let me search for that. Dec 7, 2015 at 5:38
  • 2
    Footnotes shouldn't be double spaced, when using setspace. You can do \protect\linespread{1}\protect\selectfont instead of \protect\singlespacing.
    – egreg
    Dec 7, 2015 at 9:00

1 Answer 1

2

My initial MWE was too minimal. The problem turns out to be the order of loading packages. Specifically, loading \usepackage{setspace} after \usepackage{hyperref} creates a double-spaced thanks-note. Trying to correct that by adding \protect\singlespacing to the thanks-note generates the white line in the thanks-note.

Loading \usepackage{setspace} before \usepackage{hyperref} keeps the thanks-note single-spaced.

Alternatively, Egreg's solution to add \protect\linespread{1}\protect\selectfont to the thanks-note works regardless of the order of loading packages.

For completeness, the full preamble of the actual document is as follows.

\documentclass[letterpaper,12pt]{article} 

\usepackage{amsfonts, amsmath, amssymb}
\usepackage{url}
\usepackage[left=1in,top=1.5in,bottom=1.5in,right=1in,nohead]{geometry}
\usepackage[disable,section]{easy-todo}
\usepackage[longnamesfirst]{natbib}

%% Swap the next two packages to correct the double-spaced thanks-note
\usepackage{hyperref}
\usepackage[doublespacing]{setspace}

\usepackage[font=normalsize]{subfig} 
\usepackage{graphicx}
\usepackage{multirow}                 
\usepackage{booktabs}
\usepackage{dcolumn}                  

\usepackage{pdflscape} 
\usepackage{textcomp} 
\usepackage{xcolor} 
\hypersetup{
    colorlinks,
    linkcolor={red!50!black},
    citecolor={blue!50!black},
    urlcolor={blue!80!black}
}
\usepackage{color}
\usepackage{changepage} 
\usepackage{rotating}
\usepackage{array}
\usepackage{xtab} 
\usepackage{etoolbox} 

\AtBeginEnvironment{xtabular}{\singlespacing} 
\AtBeginEnvironment{abstract}{\onehalfspacing}

\usepackage{lipsum}


\begin{document}

\title{\vspace{-4cm}\textsc{Title goes here}}

\author{Author \textsc{Goes Here}\thanks{\protect\lipsum[1]}} 

\date{\vspace{1.5em}\today}
\maketitle


 \begin{abstract}
 \noindent \lipsum[2]
 \end{abstract}

\clearpage
\section{First section}
\noindent \lipsum[5]

\end{document}
2
  • 3
    hyperref should be loaded as late as possible; only a few package should be loaded after it, notably cleveref. You're definitely loading it too early.
    – egreg
    Dec 8, 2015 at 0:09
  • 2
    There's no point in loading color as well as xcolor.
    – cfr
    Dec 8, 2015 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.