I have been trying to use a whole library and then use the in-text citation method to compile a reference section. I am getting stuck when I try to reference the whole library which is in a different directory than my latex file (I want this to stay this way, I am not looking for a solution in the same directory, if possible).

Thus far I have the following:


Within the Bibtex folder there is a library.bib file stored, which contains my citation (I have verified this). However, when I run my bibtex in Latex the following error is displayed:

"This is BibTeX, Version 0.99d (MiKTeX 2.9 64-bit) The top-level auxiliary file: Final paper.aux The style file: aea.bst I couldn't open database file C:/Users/Joachim/OneDrive/Documents/Bibtex/library.bib.bib ---line 4 of file Final paper.aux : \bibdata{C:/Users/Joachim/OneDrive/Documents/Bibtex/library.bib : } I'm skipping whatever remains of this command I found no database files---while reading file Final paper.aux Warning--I didn't find a database entry for "BDM1964" (There were 2 error messages)"

The file is saved as "library.bib" in the Bibtex folder. Any advice would be greatly appreciate.

  • additionally, I want to note that the code is before \end{document} and after all my text Dec 7, 2015 at 5:34
  • 1
    Have you tried to replace /Users/username/OneDrive/Documents/Bibtex/library with C:/Users/Joachim/OneDrive/Documents/Bibtex/library.bib
    – Guido
    Dec 7, 2015 at 6:10
  • This worked, even though I tried it earlier. I think I had to run the quick build twice to get it to work properly however, thank you! Dec 7, 2015 at 6:18

1 Answer 1


The path /Users/username/OneDrive/Documents/Bibtex/library is not recognised as a DOS/Windows path. One should use C:/Users/Joachim/OneDrive/Documents/Bibtex/library instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.