3

When I export my lyx file into *.tex it always create hard line break no matter how I do I adjust the word wrapping settings. I'm wondering whether anyone has the same problem and knows how to solve it. Thank you!

  • 1
    Why is that a problem? Does it affect PDF output? Often when you ask a question it is useful if you mention why something is a problem. It is OK to say something like "I just like it like this" (sometimes I have questions like that) but otherwise it is helpful to know what you're really after. – scottkosty Dec 9 '15 at 6:04
  • Could you add an example that shows what is going on? – Arun Debray Dec 9 '15 at 6:19
  • 2
    a linebreak in the tex source is the same as a space – David Carlisle Dec 9 '15 at 7:35
  • 1
    The linebreaks within a paragraph in the source text have no any effect in the PDF, but if this is a problem when edited, there are many tools to fix that, for example here. – Fran Dec 9 '15 at 8:26
  • For me this is a problem if I want to use a grammar checking tool on the source file. – Aquadarius Jun 19 at 4:53
5

From the LyX wiki:

If you do not want any line breaks within paragraphs, set Tools→Preferences→Output→General→Output line length to 0.

https://wiki.lyx.org/FAQ/ImportExport

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.