6

At the beginning I used

\usepackage{natbib}
\bibliographystyle{apa} 

and I really like the author-year notation. The result looks fine, but it's English and this time my seminar thesis is written in german. Within the text and the bibliography I need to change the conjunction "and" into "und", and substitute some more vocab like "pages, volume" etc.

enter image description here

There were some suggestions to this issue and the most promising is:

\usepackage[natbibapa]{apacite} 
\bibliographystyle{apacite}

I only need two implementations:

  • a cite-version "Smith et al. (2000)" in running text
  • and a citep-version "(Smith et al., 2000)" in parathesis

At the moment the apacite-solution alternative citet doesnt work for me, so all my \cite-refs are missing (questions marks within my text).

Another small but important issue are two options for the \citep

  • \citep[zitiert nach:][S. 6]{sedlacek2011economics}

Doesn't work anymore. On the other hand a minimal example works very well for me:

\documentclass[12pt,a4paper,titlepage,headinclude,bibliography=totoc]{scrartcl}

\usepackage[ngerman]{babel}                         
\usepackage[colorlinks, linkcolor = black, citecolor = black, filecolor = black, urlcolor = black, pdfborder ={0 0 0}, pdfstartview={FitH}, bookmarksopenlevel=1]{hyperref}  
\hypersetup{colorlinks=true, linkcolor=black}       

\usepackage[natbibapa]{apacite}
\bibliographystyle{apacite}

\begin{document}

I test my syntax with cite like this \cite{beck2014behavioral} and \citet{nudge2008}. And the citep command with \cite[S. 10]{nudge2008}. This also works with double citation \cite[zitiert nach:][S. 10]{nudge2008}

\bibliography{Ref}

\end{document}

enter image description here

My main-file blg. report doesn't list any mistakes. I still try to figure out the MWE/mainfile difference ..

Thank you

  • 1
    The very actively developed biblatex has proper support for language other than English, but it is not compatible with ye olde .bst files (and thus also apa.bst) it uses a different systems for bibliography styles. If you don't have to use a particular .bst file (and don't submit to a journal that does), this might be an option for you, the package has author-year styles as well. The germbib bundle has gerapali.bst a German version of apalike. – moewe Dec 9 '15 at 9:55
  • 1
    You can of course modify a copy of apa.bst yourself and change all the English words to their German counterparts. The apacite package seems to speak German as well. See also Wie formatiere ich ein Bibtex Literaturverzeichnis für eine deutschsprachige Ausgabe nach den Regeln der APA?. – moewe Dec 9 '15 at 10:01
  • I also found this link, the result looks great, but I cannot implement the solution. There is no error-report; just no result. – Mac Dec 9 '15 at 10:35
  • Please read Question mark instead of citation number and not that while you are currently using BibTeX you will need to use Biber for biblatex-apa on the link. See Biblatex with Biber: Configuring my editor to avoid undefined citations for that. If it still doesn't work you need to have a look at the .log and .blg files. (If you don't need to follow real hard-core APA style, you might find that using biblatex with just style=authoryear - or similar - also suits your needs.) – moewe Dec 9 '15 at 10:38
  • 1
    If you want to stick with BibTeX/natbib, have you tried (a) loading the apacite package with the option natbibapa and (b) specifying the apacite bibliography style? (After making these changes, be sure to delete all aux files and run LaTeX, BibTeX, and LaTeX twice more to fully propagate all changes.) Assuming you're also loading babel with the option ngerman, this setup should give you German-based citation callout and bibliography formatting features. Passing the option natbibapa to apacite ensures that you can continue to use \citep and \citet. – Mico Dec 9 '15 at 13:56
5

Assuming you want to stick with natbib-style citation commands and BibTeX and wish to adhere to the current set of formatting guidelines of the APA, you may want to look into (a) loading the apacite package with the option natbibapa and (b) specifying apacite as the bibliography style. Passing the option natbibapa to the apacite package ensures that you can continue to use \citet and \citep.

Assuming you're also loading the babel package with the option ngerman, this setup should give you German-based citation call-outs and bibliography formatting features.

After making these changes, be sure (a) to delete all aux files and (b) rerun LaTeX, BibTeX, and LaTeX twice more so that the changes are propagated fully.

enter image description here

\RequirePackage{filecontents}
%% Set up 3 test entries
\begin{filecontents}{mybib.bib}
@article{a,
  author  = "Anne Author",
  title   = "Thoughts",
  journal = "Circularity Today",
  year    = 3001,
  volume  = 1,
  number  = 2,
  pages   = "3--4",
}
@article{b,
  author  = "Anne Author and Bert Buthor",
  title   = "Further Thoughts",
  journal = "Circularity Today",
  year    = 3005,
  volume  = 5,
  number  = 6,
  pages   = "7--8",
}
@article{c,
  author  = "Anne Author and Bert Buthor and Carla Cuthor",
  title   = "Final Thoughts",
  journal = "Circularity Today",
  year    = 3009,
  volume  = 9,
  number  = 10,
  pages   = "11--12",
}
\end{filecontents}

\documentclass{article}
\usepackage[a4paper,margin=2.5cm]{geometry}
\usepackage[ngerman]{babel}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}

\usepackage[natbibapa]{apacite}
\bibliographystyle{apacite}

\begin{document}
\citet{a}, \citet{b}, \citet{c}

\citep{a}, \citep{b}, \citep{c}

\bibliography{mybib}
\end{document} 
  • Yes yes, this is great in principle! Now the german umlaut can be used directly, like ü? But book title for example dont have capital letters. Is there a way that all capital letters in my .bib-file are displayed 1to1? – Mac Dec 10 '15 at 13:39
  • So \citep and \citet work, but not the plain \cite command, right? Half of my quotes seems to be missing. – Mac Dec 10 '15 at 13:40
  • @Mac - On the topic of how to enter umlaut-characters in a bib file, please see the posting How to write “ä” and other umlauts and accented letters in bibliography? If natbibis loaded (which will be the case if apacite is loaded with the option natbibapa), \cite behaves like \citet. Please consider posting a new question on the subject of how to avoid the lowercasing of words in the title field for entries of type @book. I'm afraid I don't know how to interpret "Half of my quotes seems to be missing." – Mico Dec 10 '15 at 15:03
  • \citet seems not to work like \cite is my last big problem. There are only questionmarks for \cite as well as \citet. I'm trying to figure out the reason.. – Mac Dec 11 '15 at 13:50
  • 1
    @epo3 - yes please. – Mico Dec 7 '18 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.