1

I recently updated my Miktex distribution. After that the makeglossaries command did not work anymore. I'm using WinEdt 9.1 to call makeglossaries. I reinstalled the whole Miktex distribution and reinstalled active perl. I tried to use makeglossaries from the command prompt with the same result. I used xindy from the command prompt. This worked, so I think it's not a problem with perl. I tried to compile this MWE:

\documentclass{scrartcl}     
\usepackage[nomain,acronym,xindy,style=long]{glossaries}       
\makeglossaries    
\newacronym{a}{a}{a}

\begin{document}

\glsaddallunused[\acronymtype]
\printglossary[type=\acronymtype,]
\end{document} 

Here is the message in the log file:

makeglossaries.exe: The script is not registered.
makeglossaries.exe: Data: scriptInterpreter="perl.exe", name="makeglossaries"

MakeGlossary failed to create a gls file.
For possible explanations start the command from the Command Prompt...

Has anybody an idea what I can try next?

1

1 Answer 1

2

It was a bug from Miktex. Problem solved with the latest update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.