0

I have a document in LyX using the "American Chemical Society (ACS)" document class, with several authors from two different institutions. Some authors, however, do not have their institution displayed (the dagger symbol does not appear above their name). Currently, I have the below text in LyX (parenthesis denote the layout of each line):

Author 1 (author)

Author 1 email (Email)

Lab 1 (affiliation)

Lab 2 (alsoaffiliation)

Author 2 (author)

Lab 2 (affiliation)

Author 3 (author)

Lab 1 (affiliation)

Author 4 (author)

Author 4 email (Email)

Lab 1 (affiliation)

The goal here is to have two affiliations: Lab 1 and Lab 2. Authors 1, 3, and 4 should have the symbol denoting Lab 1, while authors 1 and 2 should have the symbol denoting lab 2.

However, when this is compiled, I get an odd result: authors 1 and 2 work as expected, while authors 3 and 4 have no corresponding affiliation symbol. If I change their affiliation to be 'Lab 3' and 'Lab 4' - so that all affiliations are different - then everything works as expected.

I am at a loss to explain this, and any help would be greatly appreciated. This seems like something that should be very simple.

Thank you!

1 Answer 1

0

Upon entering the text in LyX, one obtains the following generated TeX code,

\author{Author 1}
\email{Author 1 email}
\affiliation{Lab 1}
\alsoaffiliation{Lab 2}
\author{Author 2}
\affiliation{Lab 2}
\author{Author 3}
\author{Author 4}
\email{Author 4 email}

For some reason, the last \affiliation tags are missing. Most probably this is a bug in the LyX .layout file. The "quick-and-dirty" solution is to rather enter the required information in the preamble directly, using Document --> Options --> LaTeX preamble.

1
  • Putting everything in the preamble worked - thank you! I wish there was a more complete fix, however.
    – user93979
    Commented Dec 14, 2015 at 16:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .