I would like to abbreviate "European Commission" by "EC", also when citing a document of the EC. The problem is that the abbreviation will only be introduced when I write "\ac{EC}" (using the acronym package) in the text but not when I cite a document of the EC.

I have tried to work around this problem by writing "\ac{EC}" in the author field of my bibliography file. This works fine, except that the sorting in the references section gets messed up when using "author-year", because "\ac{EC}" is recognized as starting with an "a".

\acrodef{EC}{European Commission}

\citet{Baltensperger2015} \\



The reference section then starts with the "EC" citations instead of the "Baltensperger" one.

References EC (2013a). Quarterly report on European Gas Markets, first quarter 2013. Tech. rep. retrieved from https://ec.europa.eu/energy/en/statistics/ market-analysis. EC (2013b). Quarterly report on European Gas Markets, second quarter 2013. Tech. rep. retrieved from https://ec.europa.eu/energy/en/statistics/ market-analysis. Baltensperger, T. et al. (2015). Some title...

Any ideas how I could use abbreviations in this way and get the sorting right?

  • 2
    Try sortname={EC} or sortname={European Commission}. If that doesn't work a full MWE with the .bib entry in question would be appreciated.
    – moewe
    Dec 14, 2015 at 11:28
  • Thanks, this works! Mendeley doesn't support such a field though, so fighting on a new front now..
    – Tobias
    Dec 14, 2015 at 12:21
  • Mhhh, ask the Mendeley guys to support it. It is really the most elegant solution to this problem. I can only think of a different solution that would need Biber and not BibTeX as backend. (But when I use Biber, everything seems to work fine anyway.) Would Biber be an option for you?
    – moewe
    Dec 14, 2015 at 12:47
  • I'm really wrapping up my stuff here, so there is no point in switching for me. And Mendeley ... there are tons of requests like these and all I've seen from them in the last years were some cosmetic updates. I wouldn't recommend the software because the dev team is really disconnected from the community, but since I've started with it it's too late to change now. My solution is to write "EC" in the "translators" field, which I never use, and then find&replace it by "sortname" in the generated bib-file.
    – Tobias
    Dec 14, 2015 at 13:07
  • Sorry to hear that. I'm always very wary of the automatic export features, sometimes they get things wrong and sometimes they don't support all features. Still, I have written up a solution that mentions sortname and the fact that Biber gets it right.
    – moewe
    Dec 14, 2015 at 13:12

1 Answer 1


You can use the sortname field to specify the name used for sorting, so you would probably go for



sortname={European Commission}

If you use Biber the sorting is correct automatically, because the \ac is ignored when the sort order is determined.

For BibTeX there is the old \noopsort trick (see the TeX FAQ)

@PREAMBLE{ {\providecommand{\noopsort}[1]{}} }


author = {{\noopsort{EC}}{\ac{EC}}}
  • sortname isn't recognized by \documentclass{elsarticle}. Any ideas how the sorting could be done in that case?
    – Tobias
    Dec 16, 2015 at 9:32
  • @Tobias That is not something that depends on the document class as such, but on the bibliography package used. With biblatex the field sortname will always be recognised. But if you use a .bst file that probably won't work.
    – moewe
    Dec 16, 2015 at 9:34
  • @Tobias If the question is about BibTeX now, have a look at tex.ac.uk/FAQ-bibprefixsort.html and if that doesn't help ask a new question.
    – moewe
    Dec 16, 2015 at 9:36
  • Based on your comment, I found the following solution which works with biblatex and elsarticle and Mendeley! Just define the "author" in Mendeley as "{\noopsort{EC}}{\ac{EC}}" and add \providecommand{\noopsort}[1]{} to your preamble. Thanks moewe -> Credit should go to you, so please update your answer.
    – Tobias
    Dec 16, 2015 at 10:16
  • @Tobias I have added a short passage about the \noopsort trick.
    – moewe
    Dec 16, 2015 at 10:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .