4

I am currently working with the cleanthesis package. Customizing this thing was ok so far, but now I encountered a real problem. While trying to use minted, I wasted a lot of time till I found out it works, but not with my current cleanthesis project. For testing purposes, I made a new file with this MNWE:

% **************************************************
% Document Class Definition
% **************************************************
\documentclass[%
paper=A4,                   % paper size --> A4 is default in Germany
twoside=true,               % onesite or twoside printing
openright,                  % doublepage cleaning ends up right side
parskip=full,               % spacing value / method for paragraphs
chapterprefix=true,         % prefix for chapter marks
11pt,                       % font size
headings=normal,            % size of headings
bibliography=totoc,         % include bib in toc
listof=totoc,               % include listof entries in toc
titlepage=on,               % own page for each title page
captions=tableabove,        % display table captions above the float env
draft=true,             % value for draft version
]{scrreprt}%

% **************************************************
% Debug LaTeX Information
% **************************************************
\listfiles
\usepackage[utf8]{inputenc}     % defines file's character encoding

% **************************************************
% Information and Commands for Reuse
% **************************************************
\newcommand{\thesisTitle}{}
\newcommand{\thesisName}{}
\newcommand{\thesisSubject}{Masterarbeit}
\newcommand{\thesisDate}{}
\newcommand{\thesisVersion}{0.1}

\newcommand{\thesisFirstReviewer}{}
\newcommand{\thesisFirstReviewerUniversity}{\protect{}}
\newcommand{\thesisFirstReviewerDepartment}{}

\newcommand{\thesisSecondReviewer}{ }
\newcommand{\thesisSecondReviewerUniversity}{\protect{}}
\newcommand{\thesisSecondReviewerDepartment}{\thesisFirstReviewerDepartment}

\newcommand{\thesisFirstSupervisor}{}
\newcommand{\thesisSecondSupervisor}{}

\newcommand{\thesisUniversity}{\protect{Universität Bielefeld}}
\newcommand{\thesisUniversityDepartment}{Technische Fakultät}
\newcommand{\thesisUniversityInstitute}{}
\newcommand{\thesisUniversityGroup}{\thesisFirstReviewerDepartment}
\newcommand{\thesisUniversityCity}{Bielefeld}
\newcommand{\thesisUniversityStreetAddress}{}
\newcommand{\thesisUniversityPostalCode}{33615 Bielefeld}

% **************************************************
% Load and Configure Packages
% **************************************************


\usepackage[ngerman]{babel} % babel system, adjust the language of the content
\usepackage[                    % clean thesis style
figuresep=colon,%
sansserif=false,%
hangfigurecaption=true,%
hangsubsection=true,%
colorize=full,%
colortheme=bluemagenta,%
bibsys=biber,%
bibfile=refs,%
bibstyle=numeric,%
]{cleanthesis}
\usepackage{minted}
\begin{document}
\begin{minted}{c}
int main() {
printf("hello, world");
return 0;
}
\end{minted}
\end{document}

Any ideas what could cause this problem?

  • Rather than a working example with article, a non working one with cleanthesis would be better. – egreg Dec 14 '15 at 23:45
  • You're right, I fixed this. – Rico Dec 14 '15 at 23:50
6

You're passing draft=true to \documentclass, so it is a global option; also minted understands and accepts it.

Solution:

\usepackage[draft=false]{minted}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.