1

I am trying to continue writing a document I started a few months ago. When I tried inserting equations into the document the option was greyed out. I just updated to the newest version of lyx 2.1.5dev(July 2015) and also cleared out ~/.lyx2.1 but the problem remains exactly the same. Basically, every single option in the insert menu is greyed out.

Any suggestions on how to fix this?

5
  • Hi Tony. How can we replicate your current setup? That is paramount in order to address your concerns adequately. – Werner Dec 16 '15 at 20:17
  • @Werner , I guess to replicate the setup you would need all my settings. I just cleared /usr/share/lyx2.1 and reinstalled, but I found out that reinstalling did not recreate /usr/share/lyx2.1. I think the problem was that it was using old settings which did not correctly carry over after some update. But now, I am unable to open lyx at all because it says it cannot find some file it was expecting in /usr/share/lyx2.1. Are you aware of any way to regenerate these files? Should they be created automatically during installation? – Tony Ruth Dec 16 '15 at 20:23
  • I am unfamiliar with setting up software on Linux and/or Mac. – Werner Dec 16 '15 at 20:37
  • I cleared everything lyx related on my computer except for documents, sudo apt-get remove lyx lyx2.1 sudo rm -rf `find / -iname "lyx*"` then reinstalled and when I open a new document I still cannot insert any equations. – Tony Ruth Dec 16 '15 at 20:42
  • @TonyRuth I think my answer is the correct one. Do you have any feedback? – G.M. Apr 27 '16 at 17:55
2

(I would have put this answer in a comment first but I do not have enough “reputation points”.)

What is your Ubuntu version? My guess is the bug described here: https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/1430059. In particular see the workaround at https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/1430059/comments/20:

The proper workaround is to run lyx with the command line: QT_X11_NO_NATIVE_MENUBAR=1 lyx or equivalently to adapt /usr/share/applications/lyx.desktop as follows: Exec=env QT_X11_NO_NATIVE_MENUBAR=1 lyx %F

But the bug should be fixed now in Ubuntu, and therefore upgrading the distribution might help.

Notice that this has been cross-posted at http://www.lyx.org/trac/ticket/9905. When you cross-post a bug report, please indicate it and provide a link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.