1

I am aware of a similar question, but that answer doesn't seem to help.

I am unable to switch off ligatures when using smallcaps. The following MWE is using Minion, but I tried with many similar fonts: Dante, Merlo, Caslon, etc.

MWE:

% !TEX TS-program = LuaLaTeX

\documentclass{article}
\usepackage{fontspec}
\defaultfontfeatures{Ligatures={NoRequired, NoCommon, NoContextual}}

\newfontfamily\MinionSmallCaps
[Ligatures={NoRequired, NoCommon, NoContextual},
Letters={UppercaseSmallCaps,SmallCaps},
LetterSpace=80,WordSpace=3]
{MinionPro}

\begin{document}
\addfontfeatures{Ligatures={NoRequired, NoCommon, NoContextual}}
\MinionSmallCaps Test is here [Minion]
\end{document}

Environment on my machine:

This is LuaTeX, Version beta-0.80.0 (TeX Live 2015) (rev 5238) 
fontspec-luatex.sty    2015/09/24 v2.4e
fontspec-patches.sty    2015/09/24 v2.4e    
luaotfload.sty    2015/12/09 v2.6

Results:

enter image description here

I am able to have the desired result, using the same text and same font, using InDesign:

enter image description here

InDesign settings:

enter image description here

How can one completely switch off ligatures while using smallcaps with LuaLaTeX?


Edit 1

Writing "testate" and using "Minionpro", as suggested by @ulrike-fischer throws an error:

luaotfload-letterspace.lua:445: You cannot set field prev.next in a node of type glyph

The results is this one:

enter image description here


Edit 2

Using a similar free font, Cardo, with

\CardoSmallCaps Testate is here [Cardo]

The result is this one:

enter image description here

The ligatures are off, although the Letters={UppercaseSmallCaps,SmallCaps} directive seems not to be respected perfectly.


Edit 3

As @egreg said,

It really seems a bug in luaotfload, if not in LuaTeX.

I am monitoring luaotfload's tracker, especially this issue which seems related. I shall report back as soon as I have news.

10
  • Just to add a detail: I am aware of a recent bug in luaotfload (github.com/lualatex/luaotfload/releases/tag/v2.6-fix-1), so I have been using Luaotfload v2.6-fix-2, although the logs still say v2.6.
    – gsl
    Dec 17, 2015 at 15:07
  • 1
    It doesn't look like a ligature problem, more as if wordspace would not work at the end of words. What happens if you write "testate" and "Minionpro"? (I don't have the font, so I can't test.) Dec 17, 2015 at 15:10
  • Thanks, I have added results with your suggestion in the question. luaotfload throws an error, but it was not doing it before. I could use a different font, if you prefer?
    – gsl
    Dec 17, 2015 at 15:16
  • 1
    It really seems a bug in luaotfload, if not in LuaTeX.
    – egreg
    Dec 17, 2015 at 16:50
  • 1
    @gsl If I write estate with Linux Libertine as font, I get no letter spacing in TAT, but an error with Minion Pro. So there's some problem when letters are kerned.
    – egreg
    Dec 17, 2015 at 17:19

1 Answer 1

2

The bug seems to be solved with luaotfload version 2.6-fix-4, released 2015-12-24.

Here's the output of your very example:

enter image description here

The error with Testate does not show any more.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .