143

I'm trying to create multiple footnotes referencing from one point, that look like this:

lorem1,2

Searching for "multiple footnotes" shows up almost exclusively solutions for multiple references to one footnote. Here I have two separate footnotes, pointing from one place. I also don't want to merge them into one, because I tried it and it looks ugly.

Currently I resolved it in a quick and dirty way, writing:

lorem\footnote{foot1}$^{,}$\footnote{foot2}

Which shows up in the resulting PDF just fine, but I feel somehow bad about it. Is there a better way to do it?

5 Answers 5

113

Use the footmisc package and its multiple option.

\documentclass{article}

\usepackage[multiple]{footmisc}

\textheight=80pt% only for the example

\begin{document}

Some text.\footnote{A footnote}\footnote{And another one.}

\end{document}

enter image description here

3
  • 12
    And for use with hyperref see Holle's answer to Incompatibility between footmisc-option multiple and hyperref.
    – Stephen
    Aug 14, 2013 at 16:44
  • 2
    FWIW, I found that this setup (footmisc package with multiple option) has the first line of the footnotes indented, which was not desirable for me. Using the fnpct package (as @clemens suggested) kept my footnotes unindented. (I tried adding some of the footmisc options like para or hang, but they didn't quite match the default style I wanted.) Jan 18, 2016 at 15:13
  • It's been a while, but I would like to add to @Stephen's comment: for my use case there was no incompatibility. It just worked 😀 Aug 18, 2022 at 18:21
94

This (the footmisc solution) won't work if you also have the hyperref package loaded. Either turn off hyperfootnotes [hyperfootnotes=false] as an argument to hyperref, or use \textsuperscript{,}. This maintains the same font for the comma, whereas your workaround above inserts the math font, and it could be different.

6
  • Welcome to TeX.sx! A tip: You can use backticks ` to mark your inline code as I did in my edit.
    – doncherry
    Nov 16, 2011 at 15:15
  • 10
    This is actually mentioned in the footmisc documentation: "The hyperref package has ambitions to make hyperlinks from footnote marks to the corresponding footnote body; naturally this causes grief to footmisc, and unfortunately no remedy is currently known. If you use footmisc, suppress hyperref's hyper-footnotes, by loading it as: \usepackage[hyperfootnotes=false,...]{hyperref}. Further work on the interaction between the two packages is proposed, but not yet scheduled."
    – doncherry
    Nov 16, 2011 at 15:23
  • 1
    @doncherry footmisc uses its own command \multfootsep, which defaults to "comma in current text font". it hasn't used a maths comma since 1997 (at least); this doesn't negate the point about hyperref compatibility, of course (hyperref wasn't publicly available when i wrote footmisc, and i never quite got around to retrofitting it). Sep 13, 2012 at 10:58
  • 1
    Hey, I'm not entirely sure why, but this solution doesn't work even without the hyperref package. Any other ideas?
    – Amir Sagiv
    Feb 21, 2017 at 7:50
  • 1
    @AmirSagiv I had this problem and noticed that the footmisc package only works when the footnotes are actually adjacent. I had a line break between my footnotes, which footmisc didn't catch. Make sure there aren't any spaces/linebreaks/etc between footnotes.
    – crockeea
    Apr 5, 2019 at 16:25
42

Additionally to the mentioned footmisc and the solution “by hand” there are three more possibilities.

  1. The KOMA-Script classes offer the option footnotes=multiple:

    \documentclass{scrartcl}
    \KOMAoption{footnotes}{multiple}
    \textheight=50pt % for this example only
    \begin{document}
    Text\footnote{One}\footnote{Two}
    \end{document}
    

    enter image description here

    As this again is not compatible with hyperref KOMA-Script also offers the rather lengthy \multiplefootnoteseparator. The comma used in both cases is set by \multfootsep which is defined through

    \newcommand*\multfootsep{,}
    
  2. The memoir class natively supports multiple footnotes:

    \documentclass{memoir}
    \textheight=50pt % for this example only
    \begin{document}
    Text\footnote{One}\footnote{Two}
    \end{document}
    

    enter image description here

    Again this is not working together with hyperref so memoir also defines a macro for manual input, \multfootsep, which is defined like this:

    \newcommand*{\multfootsep}{\textsuperscript{\normalfont,}}
    
  3. Then there is fnpct - a package that was designed to offer a solution for the kerning between footnote marks and punctuation. As a sideeffect it also enables multiple footnotes that are compatiple with hyperref:

    \documentclass{article}
    \usepackage{fnpct}
    \usepackage[colorlinks]{hyperref}
    \textheight=50pt % for this example only
    \begin{document}
    Text\footnote{One}\footnote{Two}
    \end{document}
    

    enter image description here

5
  • Your answer and the información you share is unsurpassable.
    – karloswitt
    Aug 14, 2015 at 20:03
  • 1
    Awesome that fnpct works with enotez! Oct 10, 2015 at 11:00
  • 1
    Nice answer. However, automatic recognition in KOMA scrbook with footnotes=multipledoes not seem to work for me. Adding \multiplefootnoteseparator manually between the footnotes works though.
    – n1000
    Sep 20, 2016 at 8:18
  • 2
    Good answer - all I had to do was add \usepackage{fnpct} to my preamble. Also works when using hyperref.
    – AstroFloyd
    Apr 17, 2020 at 7:50
  • TOO GOOD, you saved my day (solution 3)!!!
    – mario
    Aug 23, 2021 at 15:01
34

Here is a very easy way to implement it for oneself with only four lines of code. One can redefine the footnote-command and have a look to the following command using \futurelet. If the next command is also a footnote-command a , is included. That's all. And it plays well with the hyperref-package.

\documentclass{article}
\usepackage{hyperref}

\let\oldFootnote\footnote
\newcommand\nextToken\relax

\renewcommand\footnote[1]{%
    \oldFootnote{#1}\futurelet\nextToken\isFootnote}

\newcommand\isFootnote{%
    \ifx\footnote\nextToken\textsuperscript{,}\fi}

\textheight=3cm
\begin{document}

Text\footnote{First footnote}\footnote{Second footnote}\footnote{Third footnote} Text\footnote{Fourth footnote} Text

\end{document} 

multiple footnotes

3
  • 12
    A nice tutorial on how to use \futurelet! This solution seems to be so clean and simple that I wonder what are it's drawbacks. I mean, why there is a dozen of packages and classes for multiple footnotes that all fail on the integration with hyperref?
    – Daniel
    Sep 13, 2012 at 7:42
  • Great solution, and nice not to have to load another package for something so simple.
    – John
    Aug 22, 2018 at 2:33
  • Awesome solution. Still works.
    – Mr. Panda
    Mar 2, 2022 at 15:16
1

you could also use an apostrophe written in math-mode for that:

\newcommand{\hochkomma}{$^{,}$}

For Example:

Testing multiple footnotes with commas \footnote{foonote1}\hochkomma\footnote{foonote2}\hochkomma\footnote{foonote3}

It will look like: Output of the command

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .