1

I'm under openSUSE Leap 42.1

I installed TeX Live :

 sudo zypper in texlive

Then I try to install texlive-latex but it seems that texlive package is a full package because that say me texlive-latex is already installed.

sudo zypper in texlive-latex

I don't know if it's an update or if it's a difference between debian based distros and SUSE ones, but there isn't texlive-full or texlive-latex-extra.

Than I installed Texmaker and restarted my computer.

Once restarted I launched Texmaker and try to create and compile a document name maths.tex.

But whe compiling I have this error :

Process started

warning: kpathsea: /etc/texmf/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R. warning: kpathsea: /var/lib/texmf/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R. warning: kpathsea: /usr/share/texmf/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R. warning: kpathsea: /var/cache/texmf/fonts/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R.

kpathsea: Running mktexfmt pdflatex.fmt

warning: kpathsea: /etc/texmf/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R.

warning: kpathsea: /var/lib/texmf/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R. warning: kpathsea: /usr/share/texmf/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R. warning: kpathsea: /var/cache/texmf/fonts/ls-R: No usable entries in ls-R. warning: kpathsea: See the manual for how to generate ls-R.

tcfmgr: config file `tcfmgr.map' (usually in $TEXMFMAIN/texconfig) not found (ls-R missing?). fmtutil: config file `fmtutil.cnf' not found.

Process exited with error(s)

LaTeX command is :

latex -interaction=nonstopmode %.tex

And PdfLaTeX is :

pdflatex -synctex=1 -interaction=nonstopmode %.tex

That seems to be default ones.

After that I installed Kile which installed a lot a sub-package of texlive.

sudo zypper in kile

And when compiling I have similar error :

*****
*****     PDFLaTeXsortie: 
*****     cd "/home/shark/Documents"
*****     pdflatex -interaction=nonstopmode D_maths.tex
*****
warning: kpathsea: /etc/texmf/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
warning: kpathsea: /var/lib/texmf/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
warning: kpathsea: /usr/share/texmf/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
warning: kpathsea: /var/cache/texmf/fonts/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/TeX Live for SUSE Linux)
 restricted \write18 enabled.

kpathsea: Running mktexfmt pdflatex.fmt
warning: kpathsea: /etc/texmf/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
warning: kpathsea: /var/lib/texmf/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
warning: kpathsea: /usr/share/texmf/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
warning: kpathsea: /var/cache/texmf/fonts/ls-R: No usable entries in ls-R.
warning: kpathsea: See the manual for how to generate ls-R.
tcfmgr: config file `tcfmgr.map' (usually in $TEXMFMAIN/texconfig) not found (ls-R missing?).
fmtutil: config file `fmtutil.cnf' not found.
I can't find the format file `pdflatex.fmt'!

My "/etc/texmf/ls-R" contains :

% ls-R -- filename database for kpathsea; do not change this line.
./:

Additional informations

texlive

Informations sur package texlive :
----------------------------------
Dépôt : openSUSE-leap/42.1-Oss
Nom : texlive
Version : 2013.20130620-24.7
Arch : x86_64
Fabricant : openSUSE
Installé : Oui
État : A jour
Taille une fois installé : 124,3 KiB

texmaker

Informations sur package texmaker :
-----------------------------------
Dépôt : openSUSE-leap/42.1-Oss
Nom : texmaker
Version : 4.4.1-2.3
Arch : x86_64
Fabricant : openSUSE
Installé : Oui
État : A jour
Taille une fois installé : 33,6 MiB

texlive-latex

Informations sur package texlive-latex :
----------------------------------------
Dépôt : openSUSE-leap/42.1-Oss
Nom : texlive-latex
Version : 2013.84.svn27907-17.5
Arch : noarch
Fabricant : openSUSE
Installé : Oui
État : A jour
Taille une fois installé : 1,1 MiB

kile

Informations sur package kile :
-------------------------------
Dépôt : openSUSE-leap/42.1-Oss
Nom : kile
Version : 2.1.3-8.7
Arch : x86_64
Fabricant : openSUSE
Installé : Oui
État : A jour
Taille une fois installé : 5,6 MiB
8
  • Use the direct installer of TeXLive (vanilla) and download the relevant packages. It will be more up - to - date then the prepackaged version by the Linux distribution (I am using OpenSuSE 13.2)
    – user31729
    Dec 26, 2015 at 15:25
  • Welcome! This is either a problem with the configuration of your system or a packaging problem in openSUSE which should be reported to them. I'd recommend not using their packages and installing from upstream, frankly, but the packages would create ls-R appropriately on installation.
    – cfr
    Dec 26, 2015 at 15:27
  • Please open a console and type which tlmgr. If it is not ~/home/..., you probably have to type sudo tlmgr gui. You'll get the texlive manager and under "actions" create the ls-R files.
    – Keks Dose
    Dec 26, 2015 at 15:45
  • @Keks Dose $ sudo which tlmgr which: no tlmgr in (/usr/sbin:/usr/bin:/sbin:/bin) $ sudo tlmgr gui sudo: tlmgr: command not found It seems that tlmgr is not installed
    – noraj
    Dec 26, 2015 at 18:52
  • @ChristianHupfer @cfr The vanilla install is for Debian based distros, not for openSUSE so. But may be you wanted to tell me to install TeXLive over the internet
    – noraj
    Dec 26, 2015 at 19:10

2 Answers 2

2

Finally, I installed TeXLive from the official website : Installing TeX Live over the Internet and I followed the TeX Live - Quick install documentation.

That should have worked with the ditros package too I think.

In fact I just needed to set up the paths in Texmaker parameters for LaTeX and pdfLaTeX and others paths ...

So with my install bin was in /usr/local/texlive/2015/bin/x86_64-linux.

And it's better don't forget to modify the $PATH envrionnement variable. By adding :

PATH=/usr/local/texlive/2015/bin/x86_64-linux:$PATH; export PATH in my bash.rc profile

1

Same kind of issue after upgrading the main texlive shipped with openSUSE Leap-15.3 (2017 version) with the 2021 version from Publishing:TeXLive:

warning: kpathsea: /var/lib/texmf/ls-R: No usable entries in ls-R.

Solved by

sudo /usr/share/texmf/texconfig/update

cf. https://bugzilla.opensuse.org/show_bug.cgi?id=1046277

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .