3

I am trying to save space in my CV, so now please see this picture of it:

enter image description here

Notice how Skills is aligned with its content, without leaving any blank line. However, Languages leaves too much empty space (like a blank line) and then continues. I would like it to be exactly as with Skills.

Here is my code:

\documentclass[margin,line]{res}
\usepackage[colorlinks=true ,urlcolor=blue,urlbordercolor={0 1 1}]{hyperref}
\usepackage{enumitem}
\setlist[itemize]{leftmargin=*}
\usepackage{url}
\oddsidemargin -.5in
\evensidemargin -.5in
\textwidth=6.0in
\itemsep=0in
\parsep=0in
\topmargin=0in
\topskip=0in
\newcommand{\tab}{\hspace*{2em}}
\usepackage{multicol}
\newcommand{\Myoops}[1]{\textit{#1}}
\usepackage{graphicx}
...
\section{\sc Languages}
\begin{multicols}{4}
\begin{itemize}[leftmargin=*]
  \item English (C2)
  \item German (B1)
  \item Italian (A1)
  \item Greek (native)
\end{itemize}
\end{multicols}

Also notice that this question did not solve the issue. I am also open in throwing away the list, as long as I can display my languages in one line fashion, while keeping them nicely separated.

Link to res.cls as requested: https://gsamaras.wordpress.com/code/cv-in-latex/

  • 1
    If this depends specifically on res.cls, would you mind including that code or posting a link to it? That is, does the problem still exist if you use a standard document class? – Arun Debray Dec 28 '15 at 18:10
  • To having the reader focus on the part that I think generates the issue. I will post the res.cls now, of course. – gsamaras Dec 28 '15 at 18:12
4

Try to use the inline option and itemize* instead of itemize

\documentclass[margin,line]{res}
\usepackage[inline]{enumitem}

\setlist[itemize]{leftmargin=*}
\usepackage{url}
\oddsidemargin -.5in
\evensidemargin -.5in
\textwidth=6.0in
\itemsep=0in
\parsep=0in
\topmargin=0in
\topskip=0in
\newcommand{\tab}{\hspace*{2em}}
\usepackage{graphicx}

\usepackage[colorlinks=true ,urlcolor=blue,urlbordercolor={0 1 1}]{hyperref}

\newcommand{\Myoops}[1]{\textit{#1}}
\begin{document}
\section{\sc Languages}
  \begin{itemize*}[leftmargin=*,itemjoin={\quad}]
  \item English (C2)
  \item German (B1)
  \item Italian (A1)
  \item Greek (native)
\end{itemize*}

\end{document}

enter image description here

  • Christian thanks! This is almost perfect, it worked. However, wouldn't it be nice to have some space between every item? – gsamaras Dec 28 '15 at 18:16
  • 2
    @gsamaras: Ah, yes: Use itemjoin={\quad}, for example (or two \quad\quad) – user31729 Dec 28 '15 at 18:19
  • Hey Christian, sorry for jumping into this again but I decided I want to use that again, now for two list items per row, however, I cannot see where you specified that the list items were 4 in my question at that time. Should I ask a new question or it is easy? – gsamaras Jul 24 '16 at 9:02
  • @gsamaras: There's no such option as far as I know, but you can use a `\\` after two items – user31729 Jul 24 '16 at 15:39
  • That's a bit ugly, since the li's are not vertically aligned properly and the space between the two rows is too little. I went via this solution, thanks! :) – gsamaras Jul 24 '16 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.